Page 6 of 16 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 154
  1. #51
    boogtonic's Avatar
    Join Date
    Aug 2013
    Location
    Brisbane, Australia
    Posts
    127
    +1
    16
    Do you have bad cavitation from a standstill? Loss of top speed?

    The liner is stainless pressed into aluminium on the OEM ones, salt gets in between the two and causes a blister or raised edge in the ring. You could check the clearances between the impeller and liner yourself at home if you wanted to double check the dealer..they're in your manual.

    Jerry sells those for $325 in the store, they aren't hard to swap out if you're mechanically inclined so you could save some $$ and do it yourself. Otherwise save a little further and go with the stainless steel version which doesn't blister.

    https://www.4-tecperformance.com/ind...oducts_id=1416

    I wouldn't blindly throw money at your dealer without checking yourself first anyways.


  2. #52
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,721
    +1
    109
    $500 for a wear ring that's crazy

  3. +1 by:


  4. #53
    Haven't fallen yet. MJE's Avatar
    Join Date
    May 2007
    Location
    Buzzards Bay, Massachusetts
    Posts
    484
    +1
    40
    I spoke with Dan on the phone earlier today for about 30 minutes...he was unaware of the options there are for pump housings. I believe hes going to pick up a stainless pump housing, have his impeller reconditioned and put it all in himself seeing as it's simple to do.

  5. +1 by:


  6. #54
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    886
    +1
    87
    thanks for the call. I just ordered the SS wear ring and will put it on my self. Ill be sending my solas off to get checked just incase its out of wack.

  7. #55
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    886
    +1
    87
    is this the correct one? says fits FZ SVHO not FX. is there a Difference?

    http://www.ebay.com/itm/2014-2015-Ya...-/192076732893

  8. #56
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,721
    +1
    109
    Yes it would fit your ski.

  9. #57
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    886
    +1
    87
    Update on my ski. I called to check on it considering the told me it would be ready today. They said,"oh, I was just about to Call you there is still water getting in the oil and it's because you have a line going to the intercooler and a flush kit"! He said it's leaking everywhere inside the hull and getting into the engine. I've never heard of suck a crock of dooooty in my life! Fist of all, the cooling kit is their pro cooling kit and the line is independant of the engine cooling system! its impossible for water to get into the engine. 2nd, he said water was getting into engine because it was leaking so bad it was, "sloshing around in the hull and getting into the engine". It would have to fill up the entire hull and get into the intake for that to happen and if it did, it would hydro lock. 3rd, I ran it on the hose after an oil change and there were no leaks and I got water in oil. Nothing to do with independant line or flush kit with quick connect. They are BS'ing me.

  10. #58
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    886
    +1
    87
    It's literally the dumbest excuse to get money out of someone that I've heard. Almost as bad as muffler bearings of flux compositor.... how can water get in the engine from the independant intercooler line!!!!

  11. #59
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,608
    +1
    221
    Sounds like it may be a cracked head like a few were saying
    They are just not good enough to find it

  12. #60
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    886
    +1
    87
    No. and they want to change me 400 for an oil change to get all the water out. He says its because the flush kit i have on there is leaking, hitting the seat, and spraying into the intake causing water to go past the rings, and getting into the oil. I declined that service since i can do it myself. i left a message for the service manager and he still hasn’t called me back. Very disappointed!!

Page 6 of 16 FirstFirst ... 45678 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Found an extra part in my engine
    By Antiguan FZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 10-08-2011, 10:16 PM
  2. parts not listed in kawi diagrams
    By born riding in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 10-21-2007, 11:05 PM
  3. Extra parts found!
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-22-2007, 11:56 AM
  4. Finished - But not in time for MB
    By Gatorcountry in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 05-31-2007, 04:37 PM
  5. Broken Part Found In Hull HELP!
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-14-2007, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •