Results 1 to 1 of 1
  1. #1

    Join Date
    Sep 2014
    Location
    TN
    Posts
    37

    Oil tank Issues- 99 Challenger 1800

    Long story short, tank cracked, tried repairing but no luck. Ended up purchasing a tank off ebay. No cracks/leaks, all looks good, so I got around to installing it today. The stupid thing has the filler tube on the TOP of the tank, instead of the side/corner. Didn't catch this in the ebay pictures. I've tried a multitude of hoses, and even went so far as to try to use an old 45* angle filler neck off a GSX, but that doesn't seem like it's going to work either. Probably going to just end up ordering another tank that has the filler tube in the side/corner like my original unless one of you guys have ran across this issue before and have some advice. I have looked through all the parts diagrams and none of them show this tank setup. The part number is correct, and the correct PN is also stamped into the top of the tank. All of this just seems to weird to me. Attached is a picture of the weird tank, then one of a normal tank. If anyone has any idea what boat this tank actually fits, let me know.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	tank.jpg 
Views:	28 
Size:	106.7 KB 
ID:	405431   Click image for larger version. 

Name:	tank 2.jpg 
Views:	18 
Size:	49.4 KB 
ID:	405434  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLTX and SLT 780 oil tank issues
    By xlint89 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-20-2011, 11:12 PM
  2. Oil Tank Leak
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-15-2007, 05:04 PM
  3. water in my oil tank!!!!!!
    By chris in forum Polaris Open Discussion
    Replies: 13
    Last Post: 11-15-2006, 05:29 PM
  4. Oil tank vent leaking.
    By FUBAR in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-03-2006, 06:08 PM
  5. Another Oil level issue...
    By Pale Rider in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-15-2006, 04:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •