Results 1 to 6 of 6
  1. #1

    Join Date
    Jan 2017
    Location
    Raleigh, NC
    Posts
    31

    Carburetor fuel pump Issues?

    Hello All,


    I'll try to explain this as best as I can. My Yamaha Wave Venture has always run well but the other day it ran out of fuel and sucked some junk past the fuel and i'm assuming got in to the carburetors. Now it will run fine from half to WOT but dies if i'm trying to accelerate from a idle unless I choke it for a second then it accelerates like it should. So yesterday I took the carbs apart to inspect and like I guessed they were pretty gummed up inside. Cleaned everything out and made sure all the jets were clear of junk and put them back on. Now this is where i'm getting lost. Its running the same as before, requires the choke to start but revs fine with if off but wont idle. I noticed that when running i can see fuel being dumped into the carb that has the fuel pump but cannot see any fuel being dumped into the second carb. My question is does this sound like a faulty fuel pump? clogged low speed jet? I have a rebuild kit on the way but would like to some input before I dig into them gain. Thanks in advance for you help!


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,429
    +1
    1,766
    WELCOME ABOARD GH.

    Yep cloggage lot of it. tear the carbs all the way down, make sure to clean and inspect the internal fuel filters and use compressed air to blow out everything. Check the rubber bits, best to replace them.

    make sure to get the carbs back on correctly with new gaskets and make sure the oil lines are on and in good shape plenty of how to with pics on all the other things you need to know.

    idle speed out of water is around 3k, don't run it for more then 5 seconds without cooling water,

  3. +1 by:


  4. #3

    Join Date
    Jan 2017
    Location
    Raleigh, NC
    Posts
    31
    Thanks for the reply peter.

    All the jets were clean including the internal fuel filter but it made no difference. I ordered a rebuild kit for the fuel pump & carbs due to the seals and diaphragms looking a little aged. I guess my question is do you think its a faulty fuel pump that is not pumping fuel to the second carb? or do you think the carb just needs to be rebuilt? Even though its oil injected I hate going through the process of elimination knowing that one cylinder isn't getting the proper lubrication even if its only for a couple of seconds.

  5. #4
    Did you remove the high and low screws in carbs and clean them out? Most people dont do this when they clean carbs out. Sounds to me like they need a proper strip down and rebuild.

  6. #5
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,429
    +1
    1,766
    And that also means setting the carb pop off pressures ....a step mostly ignored

  7. #6
    Does your carb have an accelerator pump (squirts gas in at when applying throttle) The outlet jets may be blocked? The fact it runs fine after half throttle shows its a blocked passage on the low end circuit This would indicate theres no gas being squirted in if it has an accelerator pump or pop off pressure/needle and seat has an issue. Didi you remove the low speed screw and clean passages out. Best way to clean a carb of gum is to fully strip it down and have it ultrasonically cleaned. Then rebuild with new kits.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gp1200 fuel pump issues and solutions... long.
    By the_natrix in forum Yamaha Old School Skis
    Replies: 39
    Last Post: 01-08-2018, 05:01 PM
  2. Fuel pump issue need input
    By ujustlost in forum Polaris Open Discussion
    Replies: 106
    Last Post: 07-20-2015, 12:38 PM
  3. Walbro fuel pump issue!!!
    By FreakRXP1200 in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-25-2010, 10:37 AM
  4. gp1200 fuel pump issues and solutions... long.
    By the_natrix in forum Yamaha PWC Performance (2-stroke)
    Replies: 27
    Last Post: 06-20-2009, 12:58 AM
  5. kawasaki 900 zxi fuel pump issue?
    By philsmtech in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-13-2008, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •