Results 1 to 6 of 6
  1. #1

    shorted battery terminals, melted wires SL700

    Long expensive frustrating story short : I have set the Ebox on the terminals of the battery and cooked some wires.

    the ground wire to block melted. the wires to the stator melted. That is all I have found so far. Does anyone have experience with this? What else is ruined? Am I in need a of new stator and/or ebox? Or could I just repair the damaged wire?


    Why Polaris designed the ski to go together like that bewilders me. I guess there was a cover of some kind but it was not with the ski as I bought it.

    thanks for any help!
    sw


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,712
    +1
    1,643
    There is a factory plastic battery cover on most/all Polaris watercraft. Why owners would discard the cover is beyond me.

    I suggest either buying a good used OEM replacement battery cover or making one from some tough flexible plastic. The lid from a 5 gallon plastic pail is what I used, trim to size and use a heat gun to fold it into shape.

    The thin black wire in the long cable bundle to the magneto stator is what usually gets fried when the battery positive post shorts to the metal shell of the electrical box. The other wires in the stator cable often get damaged by the heat.

    Check all of the thin black wires inside the electrical box for damage.

    For the stator cable you may need to remove the stator from the engine to properly inspect and repair the damage. I have posted the stator coil ohms, findable via my signature links.

  3. #3
    Quote Originally Posted by K447 View Post
    There is a factory plastic battery cover on most/all Polaris watercraft. Why owners would discard the cover is beyond me.

    I suggest either buying a good used OEM replacement battery cover or making one from some tough flexible plastic. The lid from a 5 gallon plastic pail is what I used, trim to size and use a heat gun to fold it into shape.

    The thin black wire in the long cable bundle to the magneto stator is what usually gets fried when the battery positive post shorts to the metal shell of the electrical box. The other wires in the stator cable often get damaged by the heat.

    Check all of the thin black wires inside the electrical box for damage.

    For the stator cable you may need to remove the stator from the engine to properly inspect and repair the damage. I have posted the stator coil ohms, findable via my signature links.

    Thank you, man! I know you guys get sick of 0 post accounts asking questions again and again. I lurk on here a lot though, and I have used the provided information frequently to get my ski rebuilt head to toe. Can't thank you enough honestly.

    Good tip on the cover replacement. I felt like such a moron when i realized what I had done. I knew not to let it contact, and left the ramp in a hurry to go get another battery from the house, and just let the box ride on the battery all the way home. There is heavy heat damage to the stator wire bundle, it all has to be rewired :/

  4. #4
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    854
    +1
    82
    We all start at 0 posts and at the bottom of the learning curve. Obviously, with an astonishing near 35,000 posts, K447 doesn't seem to mind. We should probably have a life insurance policy on him and a special policy form Lloyd's of London insuring his keyboarding ability.

  5. #5
    I'd rather be jet skiing Saltwater n Premix's Avatar
    Join Date
    Jul 2010
    Location
    Fort Worth, TX
    Posts
    534
    +1
    52
    I had an experience like this years ago with a 98 SXi Pro. A flame arrestor popped off and the clamp shorted between the terminals. Everything was fried CDI, coils, stator, wires, starter etc. And to make matters worse I never could crank it to flush the saltwater out of it so the engine rusted & seized by the time I got around to try and sort it out. It currently still has no spark which I believe to be a bad used stator I bought.

  6. #6
    I still have this problem, I have been too afraid to dive into it. I may get started soon. fingers crossed no actual parts got fried. I have had the Ebox split on this ski before. it looks like garbage compared to Kawi eboxes of same era. I actually logged into the hulk to post a classified to give another ski away. I need like 25 posts in two weeks to post a classified. I guess thats fair, but this ski is FREE. In Huntsville Alabama.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Positive battery terminal melted today! Anybody see this before?
    By thetolleyman in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-16-2015, 08:44 PM
  2. Help - Which Battery Terminal does this wire connect to?
    By jofa390 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-01-2012, 05:32 PM
  3. Challenger c180 Stereo questions. Battery life and wiring?
    By FLSUN in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 05-08-2009, 10:23 PM
  4. Battery Terminal Blocks
    By Dallus in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-08-2009, 05:38 PM
  5. battery cable & plug wires $20.00
    By SLOANMAN in forum Polaris Classifieds
    Replies: 2
    Last Post: 08-04-2008, 12:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •