Results 1 to 4 of 4
  1. #1

    Help Picking a Bilge Pump Spot

    Friday we are picking up a pair of GTX S 155s. This after blowing the engine in my wife's 2005 GTX. The first thing I want to do is install bilge pumps in the new skis. I have no experience with a suspension ski. Can anyone tell me the best place to install the pump. The battery is in the right rear compartment, so I don't think there is enough room there. What about the left rear compartment? That one has to be unscrewed to get into, so don't know about that one.

    Any suggestions would be appreciated.


  2. #2

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    902
    +1
    138
    I had Riva install one in my new '14 RXT-260 and the tech put it in the lowest point of the hull which is between the fuel tank and the front motor mount. I don't know if there's the same space available in a ski with the suspension configured.

  3. #3
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,389
    +1
    688
    Bilge pump needs to be in the rear of the ski because that's what will fill up first. You'll have to have a ton of water already in the ski for one in the middle to start pumping.

  4. +1 by:


  5. #4

    Join Date
    Oct 2012
    Location
    Australia
    Posts
    101
    +1
    7
    This is where I installed my bilge pump.
    Basically it's between the exhaust and the carbon seal. Not sure about a suspension ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bilge Pump help
    By jetskier90 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 03-18-2008, 06:33 PM
  2. Is this spot ok for the bilg pump?
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-14-2007, 08:10 AM
  3. help me how to install bilge pump on gp1200r-02
    By uziwork in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 07-04-2007, 10:01 AM
  4. Bilge pump runs all of the time HELP!
    By Rthomson in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-28-2007, 07:50 AM
  5. Bilge pump mounting help.....
    By OutlawGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 07-15-2006, 10:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •