Results 1 to 8 of 8
  1. #1

    Join Date
    Nov 2015
    Location
    Melbourne, AUSTRALIA
    Posts
    28

    low power, low top speed, sounds hollow slightly rough!

    Hi Guys,

    Took the 2009 GTX iS 255 out yesterday. 86hrs, SC rebuild 10hrs ago. New solas prop and wear ring 10hours ago also.

    Noticed it was down on power by about half! Top speed was only 70km/h (43ish MPH) Normally hit 110km/h/.. No codes or CELs, or dash lights...

    Slightly rough idle and sounded different in water, slightly more hollow and drone-ish...

    inspected prop and shaft, did not see anything unusual, nothing seemed to be inside pump at all..

    I did notice prop was making a noise (not sure if it was loose) when i was moving the shaft up and down.... like a metallic rattle.. (Im not sure if this is normal.?

    i might upload a vid of this also.... But may be normal...

    What could be the cause??


  2. #2
    Greggpru's Avatar
    Join Date
    Sep 2015
    Location
    Nj
    Posts
    1,516
    +1
    133
    What rpm were you hitting ? And it is normal to have some prop noise when running out of the water. Pull your sc intake tube and see if you can spinning the charger wheel by hand . Who did the sc rebuild and did they use the oem kit?

    05 rxt 77.7mph

  3. #3
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,376
    +1
    128
    As stated, check your supercharger, and be sure it did not just blown a hose off too. If the intakes system looks fine, then check the exhaust side for leaks. Check the waterbox/muffler if it blew out.

    If that all checks out, pull the sparkplugs and see if anything unusual looking there, one all black or wet etc.

  4. #4

    Join Date
    Nov 2015
    Location
    Melbourne, AUSTRALIA
    Posts
    28
    How do I assess supercharger? See if it spins freely ? Should it spin by hand?

  5. #5
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,261
    +1
    185
    No , it should not spin by your fingers !

  6. #6

    Join Date
    Nov 2015
    Location
    Melbourne, AUSTRALIA
    Posts
    28
    Thanks, will check that today.../

  7. #7
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    3,286
    +1
    1,935
    If you could move the driveshaft up and down (perpendicular from ground) you are losing a pump bearing or worse. If it slides forward/backward parallel to ground that's just play. Check wear ring. Id pull the pump if wear ring shows damage.

  8. #8

    Join Date
    Nov 2015
    Location
    Melbourne, AUSTRALIA
    Posts
    28
    SC looks ok, there is initial play of about 1cm which is quite stiff but moves a little bit and a little back again, but after that point i can not for the life of me move it at all... thinking its just the slack in the gear...

    Spark plugs look ok?? slight green tinge to the electrode tip, but no fouling.. and otherwise a nice healthy brown.

    All hoses look ok... I might put new plugs in regardless and take it out for a test again... otherwise i may need to look at the pump area... wear ring looks great though...


    hmmm

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought 08 ultra 250x, RPM's ok but low top speed issue
    By cratica in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-13-2012, 02:28 PM
  2. 2010 RXP-X Low Top Speed
    By P-ROD in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-14-2011, 09:47 AM
  3. Low top speed and not reaching max rpm?
    By Budga in forum Honda Open Discussion
    Replies: 7
    Last Post: 03-28-2011, 07:02 PM
  4. slx 780 low top speed
    By brokedown in forum Polaris Open Discussion
    Replies: 16
    Last Post: 07-23-2008, 11:24 AM
  5. 2005 GP1300R low top speed
    By Spager in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 12-09-2005, 12:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •