Results 1 to 9 of 9
  1. #1

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    348
    +1
    33

    Metal Flakes in Oil filter SC engines

    I have noticed in the past 2 SC engines I have owned a small number of metal flakes (5-7) in the oil filter after changing. (I have seen this in Automotive filters at times as well) I have never seen these flakes in NA Rotax engines, so I am guessing these come from the gear that drive the SC

    Has anyone else seen some flakes?


  2. #2
    I also saw some tiny flakes in my filter when I changed my oil for winter. Ski is an 05 rxp. Subscribed..

    Sent from my XT1254 using GreenHulk PWC Performance Forums mobile app

  3. #3
    Greggpru's Avatar
    Join Date
    Sep 2015
    Location
    Nj
    Posts
    1,520
    +1
    138
    A couple of flakes are normal and nothing to worry about . You have a pic?

    05 rxt 77.7mph

  4. +1 by:


  5. #4
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,272
    +1
    476
    Normal ....

  6. +1 by:


  7. #5
    raiderx72's Avatar
    Join Date
    Jul 2007
    Location
    Rocky Hill, CT
    Posts
    660
    +1
    67
    Agree a small amount of shavings is going to be normal. If you start seeing larger pieces and more you may have an issue

    Sent from my SM-G920V using Tapatalk

  8. +1 by:


  9. #6
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,334
    +1
    66
    aluminum flakes is fine few if them, BUT gold flakes NOT GOOD rebuilt time

  10. #7

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    348
    +1
    33
    I agree that a few flakes are very normal, however I would like to see if anyone with a NA engine is getting flakes. My theory is the flakes are from the SC drive gear teeth.

  11. #8
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    3,024
    +1
    217
    Got the same thing while winterizing today. 25 hours on the complete rebuild. This is the only one i could find.... freaked the hell out of me. It was in the pleate of the filter.


  12. #9

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    348
    +1
    33
    Interesting....I believe the primary purpose of the oil filter is not to filter the oil to keep it clean, but to catch small pieces of debris from doing damage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Little Metal Shavings in Oil Filter ???
    By Eric35 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-20-2014, 01:28 AM
  2. metal shavings in oil filter! Advice?
    By INDY27 in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-08-2012, 07:13 AM
  3. Copper flakes in oil filter
    By Zelmo in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-29-2012, 12:30 PM
  4. 06 RXP metal shaving in oil filter
    By rxp127 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-05-2011, 02:55 PM
  5. metal shavings in oil filter, what to do?
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-03-2009, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •