Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2014
    Location
    Phoenix az
    Posts
    89
    +1
    14

    R & D pump seal on new 300

    Hey guys has anyone tried the R&D pump seal on their 300 161 mm pump. According to R&D it's only rated for up to 260 hp skis. If you have tried it what kind of results have you noticed?


    Thanks Brian.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,095
    +1
    2,808
    Quote Originally Posted by AZRIVERBOY View Post
    Hey guys has anyone tried the R&D pump seal on their 300 161 mm pump. According to R&D it's only rated for up to 260 hp skis. If you have tried it what kind of results have you noticed?


    Thanks Brian.
    the R&D seal fits the 300 skis. If you check the product description in this forums online store you will see the 300 skis are listed
    https://www.4-tecperformance.com/ind...oducts_id=2295

    The 300 skis use the same exact pump as the 215/255/260 skis. The 300 skis just use a different wear ring with 161mm inner diameter.

  3. #3
    WICKEDSEADOO's Avatar
    Join Date
    Jun 2009
    Location
    SO CAL
    Posts
    1,029
    +1
    154
    Quote Originally Posted by AZRIVERBOY View Post
    Hey guys has anyone tried the R&D pump seal on their 300 161 mm pump. According to R&D it's only rated for up to 260 hp skis. If you have tried it what kind of results have you noticed?


    Thanks Brian.
    this gets rid of all the cavitation from stock pump seal.

  4. #4

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,286
    +1
    869
    Quote Originally Posted by AZRIVERBOY View Post
    Hey guys has anyone tried the R&D pump seal on their 300 161 mm pump. According to R&D it's only rated for up to 260 hp skis. If you have tried it what kind of results have you noticed?


    Thanks Brian.

    Works perfect on the 300, had mine on for over 50 hours and was on another ski for at least that many hours. It's nice if you pull the pump on and off to mess with the prop. I've seen stock ones buggered up from the factory. As long as your careful you can reuse the stock one but the R&D takes the worry factor out. I use a bunch of windex to lube it up before putting the pump on...and usually it goes right in with no issue.

  5. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Yamaha vxr vxr pump seal kit new in box
    By rcab85 in forum Yamaha Classifieds
    Replies: 6
    Last Post: 10-08-2016, 07:37 PM
  2. Motec M130 on new 300 Ski/ O2 Sensor
    By 68gmc in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-02-2016, 04:30 PM
  3. just ordered wear ring and pump seal. tips on install
    By TDSTYG in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-26-2007, 04:09 PM
  4. Can A Crappy Seal on Your Pump Shoe Scrub Speed?
    By yellow4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-26-2007, 06:35 PM
  5. WTF, I installed my new extended pump setup on my sl750
    By gvnitup in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 06-08-2007, 05:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •