Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32

Thread: GPR1200 issues

  1. #1

    Angry GPR1200 issues

    hey all!

    Was wondering if anyone would have some insight into what might be causing my gpr to be slow.. i can only get 80km/h out of her at about 6300 rpm max, everywhere i look they seem to run around 100k's at around 7000 + rpm

    - it has been recently rebuilt by previous owner... ( including the cylinders been sleeved )
    - carbs where rebuilt and re-jetted by a reputable company to suit the engine been re sleeved.
    - it was then given to another reputable company to do the fine tuning on the carbs which i think was done on a trailer backed into the water. ( apart from the lack of top speed it runs great nice and crisp throttle response ect..)
    - I have also tested the powervalves by disconnecting the cables and opening them manually and achieving the same result.
    - compression is good
    - prop seems to be in pretty good condition and was told by previous owner it is a solas 13/19 (i dont enough to know)
    - have installed a pump plug kit
    - wave eaters on the powervalves
    - also installed a works top loader grate
    - + a ff exhaust in the rear which i heard you can lose 1 or 2 mph if you arnt running higher compression (that doesnt bother me cause it sounds mean)
    - i am premixing my fuel with a fully synthetic oil at 40:1 ( tried unleaded and premium)

    what else should i look at?????? this thing is driving me nuts and do not want to throw more money at it!


  2. #2
    jgustman's Avatar
    Join Date
    Apr 2006
    Location
    Cottonwood, Mn
    Posts
    133
    +1
    5
    I would pull the jet pump and check that drive line for drag maybe a bearing going out...also check the mid shaft housing and look the impeller over. Maybe others will chime in, possible cdi issue or crank out of phase, but I think that it would have been checked with the rebuild. Need to get some of the gurus advice. First thing I thought was power valve issues, I would maybe verify they are all ok and one didn't drop, if you haven't done so already. Compression would look ok and still be an issue. Just thought of something else, maybe whoever did the jetting made it so rich it will not pull good rpms, are the plugs looking completely black after doing a plug reading/plug chop?

  3. #3
    They are all very good suggestions i will work through them. Thank you!

  4. #4
    Adam's Avatar
    Join Date
    Aug 2005
    Location
    Australia
    Posts
    354
    +1
    19
    Have you replaced the plugs ? Simple things first , I had a plug that looked ok but was breaking down and reduced the RPMs and speed /power .

  5. #5
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,343
    +1
    54
    Get or borrow a good compression gauge and see what compression is first. Sleeved cylinders are not as good as plated cylinders because of heat and port misaligned. I don't like hearing someone rejetted the carbs for what reason. Are you running aftermarket flame arresters and reed stuffers. So if we are going to make this thing run as fast as it should be we need to know what needle seat and jets it has in the carbs. And the compression. Also post some pics of the ski and engine head and carbs. Just curious if it is just a SBT engine someone put in.

  6. #6
    Quote Originally Posted by Adam View Post
    Have you replaced the plugs ? Simple things first , I had a plug that looked ok but was breaking down and reduced the RPMs and speed /power .
    yeah have replaced the plugs and double checked them!

  7. #7
    Quote Originally Posted by mudslanger View Post
    Get or borrow a good compression gauge and see what compression is first. Sleeved cylinders are not as good as plated cylinders because of heat and port misaligned. I don't like hearing someone rejetted the carbs for what reason. Are you running aftermarket flame arresters and reed stuffers. So if we are going to make this thing run as fast as it should be we need to know what needle seat and jets it has in the carbs. And the compression. Also post some pics of the ski and engine head and carbs. Just curious if it is just a SBT engine someone put in.
    hey mate have checked compression it was between 123 an 125 across all 3, im running the factory airbox and reed stuffers but all the plumbing was removed from previous owner, i have opened a bit more air up to the hull. when i bought the ski it come with a bunch of recipts ill list them all....
    - sleeve barrels, bore and hone
    - WSM piston kit yamaha 1200r std bore ( piston, rings, wrist-pin, circlips)
    -WSM piston wrist pin needle bearing
    - top end gasket kit
    - winderosa mikuni carb rebuild kit
    - WSM cylinder sleeve
    - crankshaft and seals
    - driveline kit
    - WSM driveshaft
    - WSM coupler shaft
    - solas impeller remover tool
    i believe the previous owner rebuilt it himself

    i had the carbs rebuilt - high jets 145, 1.5 needle and seat
    also if i squeeze the throttle to quick from a slow speed it will bog and nearly stall especially if i have been in a no wake zone for a while. I was also thinking maybe it was just a prop issue as it cavitates ALOT holeshot i have installed the PPK but didnt seem to do much at all, on the hose and when it cavitates at holeshot it will rev over 7000 rpm but under load and top speed will only sit around 6300ish (thats according to the factory taco) but have been using GPS for top speed runs. I will post some pictures as soon as i figure out how!

  8. #8
    Click image for larger version. 

Name:	1477731775699-2033767710.jpg 
Views:	44 
Size:	46.1 KB 
ID:	401670Click image for larger version. 

Name:	1477731775699-2033767710.jpg 
Views:	44 
Size:	46.1 KB 
ID:	401670
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1477731601302356023720.jpg 
Views:	38 
Size:	168.2 KB 
ID:	401669  

  9. #9
    Adam's Avatar
    Join Date
    Aug 2005
    Location
    Australia
    Posts
    354
    +1
    19
    What country are you in ?

  10. #10
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,343
    +1
    54
    The 145 high speed jet is too big for your setup a 125 would be plenty. What is the low speed jet? Also did you replace the 1 inch by 6 inch long rubber gasket under the pump shoe where the pump shoe meets the transom plate. If everything isn't sealed properly it will cavitate like crazy. If it is cavitating bad it will scrub a lot of top end speed. If the flame arrester plate is still in the air box that 145 high speed jet is flooding the engine. What is the high and low speed adjusters set at. You need a digital tach also.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gpr1200 bogging issues
    By ashers in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-10-2014, 06:08 AM
  2. 01 GPR1200 Pump Shoe Seal Kit Issue
    By pizbrewin in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-18-2013, 11:01 AM
  3. Just friggin great - gpr1200 issue
    By vincerho in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-29-2011, 08:08 PM
  4. who knows if Seadoo will cure the supercharger issue in 2006
    By rxp_boy in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-17-2005, 09:30 PM
  5. 2003 1300GPR HULL ISSUES
    By RXPNJ in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-24-2005, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •