Results 1 to 8 of 8
  1. #1

    Beep, Engine Light, Power Loss.....What Gives?

    Ok guys so I was out this weekend on my 2015 GTR (stock, 30hrs) and something weird happened. Went over a tiny wake of another ski approx 15-20 mph, couple of quick small bumps in succession, nothing major. Then heard the ski beep loudly and immediately let off the gas. I looked down to see the engine light come on. Then tried to feed it some gas gently and nothing. Zero throttle response. I was out in the middle of nowhere so decided to try and turn it off then back on hoping it was some sort of hiccup. Came back to life no problem after that with no more engine lights and worked fine for the next 30 min.

    So:
    A) Random gremlin, just ignore it?
    B) Something is up/broken and I need to check it? But what? Rather avoid the dealer and the $300 fee to just enter the front door. Can check/fix myself if I know what I'm looking for.
    C) It's a POS, just buy a Yammi? Just kidding of course

    TIA!


  2. #2
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,375
    +1
    256
    My wifes' 2015 GTI 130SE does the same thing, in my case it throws a IBR fault. Only after coming down hard on a wave, power down and restart good as new.

  3. #3
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66
    C lmaooo

  4. #4
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66
    C lmaooo may by you tip over sensor some time go bad

  5. #5
    Quote Originally Posted by moparguy View Post
    My wifes' 2015 GTI 130SE does the same thing, in my case it throws a IBR fault. Only after coming down hard on a wave, power down and restart good as new.
    Had to put that in there didn't ya?

    Quote Originally Posted by rxpredviper View Post
    C lmaooo may by you tip over sensor some time go bad
    Where is this bad boy? Something that I can check or dealer only?

  6. #6
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66

  7. #7
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66
    #25 that part work with a magnet

  8. #8
    Thank you! I will check it to make sure it's not loose or something.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 06-24-2015, 03:55 PM
  2. Intermitent power loss with warm engine
    By jparinel in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 07-15-2011, 12:13 PM
  3. Intermitent power loss with warm engine
    By jparinel in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 06-24-2011, 10:41 PM
  4. Single Beep, Check Engine Light...
    By JDougM5 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-19-2010, 09:10 PM
  5. Please help! Check Engine Light & Warning Beep
    By holdnon72 in forum Sea Doo Sport Boats
    Replies: 8
    Last Post: 06-07-2009, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •