Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 43
  1. #1
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66

    2016 please post you problem of new 300

    probably buying one for wife and i like to know what are the problem.
    thank you


  2. #2

    Join Date
    Nov 2008
    Location
    greece,Europe
    Posts
    95
    +1
    8
    ​none....80 hours ocean ride...gtx 300 limited

  3. +1 by:


  4. #3
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,298
    +1
    66
    Quote Originally Posted by rxpsalonika View Post
    ​none....80 hours ocean ride...gtx 300 limited
    stock ??

  5. #4
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,236
    +1
    44
    So far just a broken exhaust clamp @ 9 hrs

  6. +1 by:


  7. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,370
    +1
    867
    I have not had one problem, but did have the updates done because I bought one of the first ones. I did also tighten all my clamps and inspect the whole ski before use. I did have a hull that was not finished properly from the factory, so I would inspect the complete ski before purchase.

  8. +1 by:


  9. #6
    CTrider's Avatar
    Join Date
    Oct 2015
    Location
    CT
    Posts
    83
    +1
    9
    No problems with 50 hours of salt and fresh use. SCOM and catch can installed. Tightened all clamps from factory and had the dealer check for the head bolt recall as I received mine in February of this year. IMO very solid ski.

  10. +1 by:


  11. #7
    jeel's Avatar
    Join Date
    Jul 2010
    Location
    Toms River NJ
    Posts
    509
    +1
    63
    I was hesitant on buying a first year ski...i found one with less than 10 hrs on it in september...i had my dealer check the vin for any recalls or updates and there were none ..i even called BRP and they said mine was a later build( 04 /16)and there were no recalls....with that being said i checked every clamp and a good percentage of them were loose...if you are not buying from a dealer call brp and have them check the vin for you..i currently have 18 hrs and it runs great..i added a scom and get a steady 76 mph on gps 78 on dash...
    Last edited by jeel; 10-14-2016 at 08:31 PM.

  12. #8
    Dark Horse's Avatar
    Join Date
    May 2016
    Location
    Lakeside, MT
    Posts
    74
    +1
    8
    Rub rail split in half with less than 10 hours, happened while I was just cruising around. Other than that mishap it's been a pretty solid machine.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_6512.jpg 
Views:	101 
Size:	126.8 KB 
ID:	400928   Click image for larger version. 

Name:	IMG_6507.jpg 
Views:	859 
Size:	115.5 KB 
ID:	400929  

  13. #9

    Join Date
    Nov 2008
    Location
    greece,Europe
    Posts
    95
    +1
    8
    Quote Originally Posted by rxpredviper View Post
    Quote Originally Posted by rxpsalonika View Post
    ​none....80 hours ocean ride...gtx 300 limited
    stock ??
    only scom and grf catch can

  14. #10
    Ken62465's Avatar
    Join Date
    Apr 2011
    Location
    Gardner, MA
    Posts
    616
    +1
    51
    Riva scom and 37hrs..not a lick of issues thus far. It's been solid and can't complain. I went over it thoroughly to make sure SB's were done and my own anal inspection.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What do you think of my new wheels?
    By boataddict in forum Open Discussion
    Replies: 26
    Last Post: 04-08-2009, 09:39 PM
  2. Can someone please post a pic of a Gray line?
    By ppkarnezis in forum 2-Stroke Performance
    Replies: 6
    Last Post: 02-27-2009, 12:07 PM
  3. Please post pics of RXT intake grates
    By Gus13letter in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-07-2009, 03:43 PM
  4. So what do you think of the new RXP??
    By BOOSTED in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-23-2006, 08:30 AM
  5. Pictures of Rotax Racing's new 300 HP system
    By Green Hulk in forum 4-Tec Performance
    Replies: 32
    Last Post: 05-12-2005, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •