Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20

    03 polaris genesis 1200 di

    Ok thanks for any time you give to this.I have a no spark no fuel situation with my ski.I have tested the following:26volts dc at injectors while cranking.power on the 8 pin connector at the eem on the 2 pink wires.150 ohms on the cps.bypassed the startstop module and still no spark or fuel.I have 0.2 ohms on the lanyard switch without the key.installed the key and it's open or "ol".I have no rpms when cranking and the display will not wake up when I try to start.I have bypassed the startstop module,disconnected the tps and attempted to start with lanyard in place.turns over.no spark no fuel.any ideas?thanks for helping!allen.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632
    Four pin diagnostic loopback connector unplugged or white/red wire broken?

  3. #3

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20
    No sir the wire is intact with a secure connection

  4. #4

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20

    genesis di

    The ski just died on the lake out of nowhere.I am suspicious of the lanyard kill switch but need good testing information on how to rule it out.it is the original eem with 500+hrs of that helps

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632
    Quote Originally Posted by boardncrash View Post
    The ski just died on the lake out of nowhere.I am suspicious of the lanyard kill switch but need good testing information on how to rule it out.it is the original eem with 500+hrs of that helps
    Find one of my lists where I describe how to bypass the LR-503 start/stop module (with plug connector). Bypass the module. See if engine now starts and runs.

  6. #6

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20
    I have done the bypass including disconnecting the tps with the lanyard connected.still nothing.

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632

    Arrow How to test lanyard stop switch on Ficht Genesis and Virage

    Quote Originally Posted by boardncrash View Post
    I have done the bypass including disconnecting the tps with the lanyard connected.still nothing.
    Connect ohmmeter to the black/yellow ignition kill wire, and black wire (ground).

    Black/Yellow wire goes the the LR-503 module, and pin-8 on the big EMM connector, and there is a wire harness splice connector with several black/yellow wires (remove the splice connector cover to access the metal buss bar inside). Any of these will do as a test point.

    Should measure zero ohms with lanyard out, open circuit with lanyard in.

    Sometimes the plastic U-clip on the lanyard is a little bit too thin and allows the kill switch to activate despite having the lanyard inserted. The Kawasaki lanyards a thicker and can hold the switch open more firmly.
    Last edited by K447; 10-11-2016 at 08:56 AM.

  8. #8

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20
    I will conduct that test and let you know of the results.thank you for your help and knowledge.allen

  9. #9

    Join Date
    Jun 2015
    Location
    waynesboro pa
    Posts
    20
    I have 0.3 ohms with the lanyard out and open with it in.is the 0.3 acceptable or are you looking for zero?

  10. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    38,641
    +1
    1,632
    Quote Originally Posted by boardncrash View Post
    I have 0.3 ohms with the lanyard out and open with it in.

    is the 0.3 acceptable or are you looking for zero?
    0.3 ohms is probably your ohmmeter offset/error. Well within reasonable for a good switch.

    Did you wiggle the lanyard clip while monitoring the switch for open circuit? If the lanyard switch closes even momentarily with the lanyard clip in place, that will shut down the running engine.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WTB Stator for Polaris Genesis 1200 DI
    By Harsax13 in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-22-2015, 06:25 PM
  2. FS Polaris cover for Genesis 1200 DI
    By vxrpete8 in forum Polaris Classifieds
    Replies: 6
    Last Post: 10-06-2009, 02:57 AM
  3. Info Needed On Polaris Genesis 1200 Carb
    By A1999polaris1200ccgenesis in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-29-2008, 07:56 PM
  4. polaris genesis 1200 mods
    By polarisgen1200 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 09-10-2007, 06:08 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •