Results 1 to 7 of 7
  1. #1

    2001 Polaris Virage TX requires security reset every 5-10 mins while riding.

    Hi,

    I am new here and new to jet skis, although I am experienced in automotive mechanics and electrical/electronics.

    I have a 2001 Polaris Virage TX and while riding the display will randomly, usually after 5-10 mins of riding, state at the bottom "UNLOCKED", the engine runs badly and has about half power. Then I push the "lock" (middle button) on the display, the display will state "PLEASE RIDE RESPONSIBLY", I let off the throttle and then it will run great again until this issue repeats again in 5-10 mins. This happens continuously without fail.

    It was like this when I bought it a couple months ago. The previous owner told me to push the "lock" button to make it run properly.

    Thank you for any helpful information.

    Dean


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,390
    +1
    1,745
    Welcome

    This is a carburetor engine, correct?

    Let it sit for for more than five minutes with engine off, lanyard in place. Do not press any other buttons. Display should say 'UNLOCKED'. Press the Start button and start engine.
    Does the MFI display 'wake up' immediately as soon as the engine starts?

    Does the display show the correct RPM while the engine is running?

    What is the battery voltage with engine running?
    Measure with a multimeter, not using the dash display.

    Are there any signs of damage or moisture inside the MFI display?

  3. #3
    K447,

    It is carbureted and there is LCD distortion in the display. Thank you for the information. I will do that exactly as you proscribe as soon as I can but it may be a while as I am going out of state for work for several weeks and have much to do to prepare.

    I appreciate your help.
    Dean

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,390
    +1
    1,745
    Quote Originally Posted by Dean81147 View Post
    ...
    It is carbureted and there is LCD distortion in the display.
    ...
    Do the checks, but generally if the MFI display type has internal problems the solution is to replace the entire MFI unit. The smaller older model MFD versions are different in this regard.

    Good news is that replacement MFI display can come from a number of Virage and even Genesis models.

  5. #5
    K447,

    Can I swap the display from my same year TXI (fuel injected) to see if that solves it? The TXI has a problem with the reverse not functioning, stays in forward. It does nothing at all. I checked the switch, it's good, and no power is reaching the motor. All fuses are good. I think it has display issues also, but not as bad as the TX. I live in CO, so they are not going to be used for until next spring. I plan to go through them extensively.

    I bought them to have a little fun and sell them later, but I think I changed my mind. They're just too fun.

    Thanks again.

  6. #6
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,390
    +1
    1,745
    Quote Originally Posted by Dean81147 View Post
    ...

    Can I swap the display from my same year Virage TXI (fuel injected) to see if that solves it? .
    Yes, no problem swapping those MFI displays.

    Be careful not to loose the mounting springs from behind the display. They can fly off when unhooked and then hide.

  7. #7
    OK, I will be careful. I will get back with more info as soon as I can. Have a great weekend. Thanks for all your great help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris virage tx, wont start again after shutting off.
    By dockeffer in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-12-2016, 05:12 PM
  2. 2001 polaris virage tx running poor!!
    By gary s in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-10-2011, 08:32 PM
  3. FS 2001 Polaris Virage TX
    By pirate33 in forum Polaris Skis
    Replies: 6
    Last Post: 06-27-2010, 12:45 AM
  4. 2001 Polaris Virage TX Bogs Down at 2000-3000rpm
    By frewworld in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-30-2009, 09:37 PM
  5. New Toy 2001 Polaris Virage TX Injected
    By 800AMSOIL4U in forum Polaris Open Discussion
    Replies: 24
    Last Post: 04-19-2008, 11:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •