Results 1 to 6 of 6
  1. #1

    2007 Kawasaki Ultra 250x No boost and Low RPM

    2007 Kawasaki Ultra 250x has no boost on gauge and runs about a top of 3500 rpm and 5 mph top, cleaned out intercooler that has some water and oil and super charger pulley turns freely. Changed spark plugs. Im out of ideas what else to look for. Perfect compression accross all cylinders.


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,350
    +1
    659
    A PERFECTLY free spinning supercharger does not mean good
    you must be able to feel the insides turning and if you try to spin in fast you can hear it pumping air

    it can have a broken shaft and just be spinning on the. Pulley bearing.

    Waz

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    sounds like a broken s/c shaft as per waz above. loosen the belt and spin the pulley you should feel resistance and hear it pulsate.

  4. #4
    Yeah there is some resistance when I took the belt off it doesn't spin freely it does take a little to turn and no scrape sounds or anything, I did notice the tensioner pully is a little hard to turn but I'm not sure how easy it is supposed to be to turn. Also notice the tensioner pully tension screw was so loose I could turn it by hand. It seems like that should be tighter than it was. Just let me know what you think.

  5. #5
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,221
    +1
    1,076
    Quote Originally Posted by zthuner View Post
    2007 Kawasaki Ultra 250x has no boost on gauge and runs about a top of 3500 rpm and 5 mph top, cleaned out intercooler that has some water and oil and super charger pulley turns freely. Changed spark plugs. Im out of ideas what else to look for. Perfect compression accross all cylinders.
    You are aware that you are in the Polaris section, correct?

  6. #6
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,636
    +1
    184
    Quote Originally Posted by CrazyA View Post
    Quote Originally Posted by zthuner View Post
    2007 Kawasaki Ultra 250x has no boost on gauge and runs about a top of 3500 rpm and 5 mph top, cleaned out intercooler that has some water and oil and super charger pulley turns freely. Changed spark plugs. Im out of ideas what else to look for. Perfect compression accross all cylinders.
    You are aware that you are in the Polaris section, correct?
    someone moved this to the wrong section..... it was originally in the Kawasaki section. the OP is not to blame for this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just bought a 2007 Kawasaki Ultra 250x and it idles between 920 and 1650
    By tyrock22 in forum Kawasaki Open Discussion
    Replies: 16
    Last Post: 06-15-2013, 07:05 PM
  2. 2007 Kawasaki Ultra 250x no start
    By rave1982 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 20
    Last Post: 04-04-2012, 04:27 PM
  3. 2007 Kawasaki Ultra 250X low rpm
    By saynotospam in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-10-2011, 09:57 PM
  4. 2007 Kawasaki Ultra 250x Red 17hrs in NJ
    By NJMatt50 in forum Kawasaki Skis
    Replies: 3
    Last Post: 08-08-2008, 11:14 AM
  5. FS 2007 Kawasaki Ultra 250x - Red Rocker
    By bwilso1 in forum Kawasaki Skis
    Replies: 7
    Last Post: 06-26-2008, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •