Results 1 to 7 of 7
  1. #1
    redbarron's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville, FL
    Posts
    68
    +1
    1

    Hitting only 70mph?

    Hello all. I have a 2012 RXT-X with following mods:

    V-Tech 8375
    Fizzle F1000
    Soals 15/19

    I am hitting a indicated 70MPH with these mods. Ski has a brand new Solas, Wear ring and pump bearing. I am turing a consistent 8050RPMS at an indicated 70MPH. Any ideas, I always thought it would be a few MPH faster.


  2. #2
    RiverRat71's Avatar
    Join Date
    Apr 2016
    Location
    Flint River, GA
    Posts
    400
    +1
    73
    You need a bigger air intake tube (Riva Power Filter or just an adapter & Kanaflex. That should add about 150-200 rpm's & let you take advantage of the V-Tech program & the 15/19.

  3. +1 by:


  4. #3
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,387
    +1
    688
    If 4" air intake doesn't bring you over 8200 take 1mm off your impeller, that will give you extra ~100 rpm.

    The trailing pitch might be more than what it says on the impeller.

  5. +1 by:


  6. #4

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    767
    +1
    2
    It must be a Jacksonville thing because I have a buddy with the same set up except he has the 4" kana flex and his Is a rxpx 260 and all he see on the dash is 71-72 MPh and that is at 8260-8300 rpm...I thought he would see 74-75 at least

  7. #5
    11c's Avatar
    Join Date
    Aug 2015
    Location
    Winnipeg, Manitoba, Canada
    Posts
    148
    +1
    15
    Quote Originally Posted by cliff0413 View Post
    It must be a Jacksonville thing because I have a buddy with the same set up except he has the 4" kana flex and his Is a rxpx 260 and all he see on the dash is 71-72 MPh and that is at 8260-8300 rpm...I thought he would see 74-75 at least
    It must be real hot and humid when they were riding ..RPM is not really over stock? (8050)
    Maybe crappy premium fuel and it's pulling timing.? I'd try another gas station
    Must be good air up here because I'm running the stock air intake assembly and intercooler and get 74- 75 @ 8200 in the heat and upper 70's in cool weather, even hit 81 on the speedo (pic posted in another thread of speedo recall ) going with the current at 8440 one morning. Actually that was the maiden voyage with the tune, prop and flame arrestor removed so I was very happy. I'm going to try to get a video clip of a run hopefully before I put them away for the winter.
    I hear salt water yields slower speeds too...

  8. #6

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    767
    +1
    2
    We rode yesterday morning temp was perfect around 84 degrees water was flat...rpms was 8300 dash only showed 70mph against the tide and with the tide he saw 72...he also has flame arrester removed

  9. #7
    redbarron's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville, FL
    Posts
    68
    +1
    1
    Quote Originally Posted by cliff0413 View Post
    We rode yesterday morning temp was perfect around 84 degrees water was flat...rpms was 8300 dash only showed 70mph against the tide and with the tide he saw 72...he also has flame arrester removed
    I was out yesterday as well. Great day, I also hit 72 indicated on the spedo. Must be a Jax thing....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLX Hitting Only 5850 RPM At WOT
    By dmueller9834 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 08-13-2014, 09:17 PM
  2. raider hits 70mph again
    By big raider in forum Yamaha Old School Skis
    Replies: 48
    Last Post: 11-16-2010, 12:57 PM
  3. 04 RXP only hitting 7600 rpm
    By snowrunner in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-29-2009, 08:21 PM
  4. With these mods only hitting 65mph ??
    By SpeedyKJ in forum Kawasaki PWC Performance (4-stroke)
    Replies: 60
    Last Post: 09-22-2007, 03:10 PM
  5. New ski only hitting 25mph
    By eclipsecleaning in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-14-2007, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •