Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,651
    +1
    159

    2005 sportster back from the dead.

    Well guys I picked up one of these little boats at a deal. Paid 1200 with a brand new trailer. Motor dropped a valve and did what they do. I've got a motor here that I'm gonna install with an X charger and 42s and just run it around for a summer or 2. I'll post up pics along the way. Seats need redone and it's missing the compartment cover on the driver and passenger side:/ should be fun.


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2275.jpg 
Views:	420 
Size:	144.0 KB 
ID:	399969  


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,959
    +1
    1,414
    Latch pics. Click image for larger version. 

Name:	20161012_171347.jpg 
Views:	50 
Size:	17.1 KB 
ID:	400765Click image for larger version. 

Name:	20161012_171337.jpg 
Views:	57 
Size:	17.9 KB 
ID:	400766Click image for larger version. 

Name:	20161012_171331.jpg 
Views:	54 
Size:	15.7 KB 
ID:	400767Click image for larger version. 

Name:	20161012_171324.jpg 
Views:	53 
Size:	26.4 KB 
ID:	400768

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,959
    +1
    1,414
    Click image for larger version. 

Name:	20161012_175712.jpg 
Views:	55 
Size:	17.5 KB 
ID:	400773Click image for larger version. 

Name:	20161012_175722.jpg 
Views:	55 
Size:	10.6 KB 
ID:	400774Click image for larger version. 

Name:	20161012_175729.jpg 
Views:	53 
Size:	12.9 KB 
ID:	400775

  4. #4
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,651
    +1
    159
    Thanks so much beer!! I need to maybe get you on the phone. I've got a random wire behind all the gauges. Yours is an 05? Here's the wire


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2294.jpg 
Views:	373 
Size:	42.0 KB 
ID:	400813  

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,959
    +1
    1,414
    Mine is an 07. There are several Blue wires behind the dash.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Capture.jpg 
Views:	377 
Size:	59.0 KB 
ID:	400825  

  6. #6

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    917
    +1
    17
    The wire looks like one that would plug in to the back of 1 of the gauges.

  7. #7
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,651
    +1
    159
    Hmm, all gauges and lights and buttons work... I'll keep reading the manual

  8. #8
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,651
    +1
    159
    Well.. got some replacement seats and getting covers made from zz auto.. slowly comming along. Motor and pump is installed. Need to install new steering cable and take for water test

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_2360.jpg 
Views:	333 
Size:	76.1 KB 
ID:	401613  

  9. +1 by:


  10. #9

    Join Date
    Jun 2009
    Location
    Tierra Verde, Florida, United States
    Posts
    917
    +1
    17
    ZZ does great work! I have had 4 or 5 projects done with his skins. Make sure he know yours seats are 07 or 08 and not the 05s. They are different. Looking good

  11. #10
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,651
    +1
    159
    Emailed with him a few times. Amazing service. Got her out for test run. Small leak around new streering cable. Old cable had silicone around it... any tips for this?? Ran smooth and sound... tach doesn't work so couldn't really hammer on it.. X charger and Rotax racing ecu is way too much power for stock prop lol. Don't wanna be hammering on the limiter... anyone have any tachs? Boat ran 50.4mph and had tons of throttle left.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The $700 Octane: Back from the dead
    By caliburst in forum Polaris Projects
    Replies: 215
    Last Post: 03-16-2017, 01:58 PM
  2. Msx 140 back from the dead
    By jetski4ever in forum Polaris Projects
    Replies: 18
    Last Post: 01-27-2015, 10:07 PM
  3. SLT Back from the Dead
    By dolson in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-20-2014, 05:10 PM
  4. "Project Midnight" Another 01 SLX back from the dead!
    By fixer in forum Polaris Projects
    Replies: 40
    Last Post: 05-30-2014, 05:39 PM
  5. Another polaris saved! 01 SLX back from the dead.
    By caliburst in forum Polaris Projects
    Replies: 128
    Last Post: 01-06-2014, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •