Results 1 to 7 of 7
  1. #1
    DP.'s Avatar
    Join Date
    Aug 2007
    Location
    Cayman Islands
    Posts
    430
    +1
    6

    F15x smoking and burning oil

    Hi all, I have a 2009 F15x turbo that was laid up for two years, after restarting the engine and water testing it, I noticed a lot of smoke coming out the exhaust and the engine breather on the engine, also the oil gets low and the low oil sensor puts it in limp mode. the engine still runs and sounds good when new oil is added but I would like to know if anyone here has encountered this kind of problem and what did they find to be the solution? Any help would be greatly appreciated!

    Thanks
    DP


  2. #2
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,755
    +1
    183

    F15x smoking and burning oil

    Maybe rings are stuck or turbo seals are shot , do a conprecion test on all 4 cylinders to see what you get and take pictures of all 4 plugs and don't mix them up to confirm each cylinder.
    Last edited by DR2006RXP; 09-26-2016 at 07:34 AM.

  3. #3
    DP.'s Avatar
    Join Date
    Aug 2007
    Location
    Cayman Islands
    Posts
    430
    +1
    6
    Thanks for the reply DR200. Here's what I found, checked the compression: #4-170psi, #3-150psi, #2-150psi, #1-90psi also removed the Turbo and found it full of oil on the inducer side as well as the exducer side was very wet with oil. Can this factory turbo be rebuilt, it doesn't look so, the shop manual does say that there is ceramic bearings in the turbo but it doesn't say anymore than that about the it.
    Thanks again.
    DP

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,925
    +1
    290
    turbo oil seal bad

  5. #5
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,755
    +1
    183

    F15x smoking and burning oil

    Quote Originally Posted by DP. View Post
    Thanks for the reply DR200. Here's what I found, checked the compression: #4-170psi, #3-150psi, #2-150psi, #1-90psi also removed the Turbo and found it full of oil on the inducer side as well as the exducer side was very wet with oil. Can this factory turbo be rebuilt, it doesn't look so, the shop manual does say that there is ceramic bearings in the turbo but it doesn't say anymore than that about the it.
    Thanks again.
    DP
    Compression is normal depending on the model 171 on turbo and 181 on non turbo but that 90 psi reading is low on that 1st cylinder, the turbo could be purchased new on eBay or you could get it rebuild from Jetski int he does quality rebuilds . I am working on a Honda as we speak has 80 psi on all 4 and turbo is shot and won't power on.Click image for larger version. 

Name:	IMG_6259.JPG 
Views:	41 
Size:	316.7 KB 
ID:	399817Click image for larger version. 

Name:	IMG_6260.JPG 
Views:	40 
Size:	294.1 KB 
ID:	399818Click image for larger version. 

Name:	IMG_6261.JPG 
Views:	42 
Size:	279.0 KB 
ID:	399819Click image for larger version. 

Name:	IMG_6262.JPG 
Views:	47 
Size:	348.6 KB 
ID:	399820

    I would do a leak down test on that first cylinder to see why it's low, intake valves leaking , exhaust valves or bad rings and the pressure goes down to the case .
    Last edited by DR2006RXP; 09-26-2016 at 07:10 PM.

  6. #6
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,755
    +1
    183
    Quote Originally Posted by JoeyDFZS View Post
    turbo oil seal bad
    Do you have a compatible part number ??

  7. #7
    DP.'s Avatar
    Join Date
    Aug 2007
    Location
    Cayman Islands
    Posts
    430
    +1
    6
    Thanks for the replies guys, I'll let you all know what I find with the leak down test.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 STX-12f smoke and oil out exhaust and in air box
    By furn1593 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 07-23-2012, 12:09 AM
  2. Rxp-x water in oil and burning oil help
    By onelegman in forum 4-Tec Performance
    Replies: 9
    Last Post: 02-26-2012, 09:27 PM
  3. Using/burning oil and down on RPM
    By MVR 155 in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-28-2010, 09:39 AM
  4. msx 150 smoking and using oil HELP
    By ln69bt in forum MSX/Matrix
    Replies: 1
    Last Post: 03-23-2008, 08:47 AM
  5. Smoke and smell after winter
    By mickey78 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-31-2006, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •