Results 1 to 7 of 7

Thread: How to newbie

  1. #1

    How to newbie

    Hi,

    new here I have a Polaris slt X, it's been sat a while but then engine is spot on so I've got some new plugs on order and with abit of easy start and fresh fuel I've going to fire her up this week after 6 months. Is there any thing else I should do?

    Now couple of questions I've ordered a new drain plug that screws into the hull, is this a simple job do I need any sealants etc ans the rubber one that's in there is a rubber bung with a hole in, which we use to screw a bolt into and that was suffice. I'm looking to remediate this long term now. But am planning on taking it out for the weekend so don't want no leaks.


    Secondly the ski ran fine but wouldn't idle, is there an idle adjustment screw or some way of fixing this?


    Regards jack


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,382
    +1
    1,745
    For the new captive drain plug, drill the screw holes carefully to the correct size and location. The hole size matters as the hull material will not give like wood.

    Use a thin head of marine sealant behind the captive drain plug body, then install. Wipe excess squeeze out away after snugging the two mounting screws. Do not allow sealant to get onto the thread plug or into the drain hole.

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,382
    +1
    1,745
    You are starting a machine that has sat for six months, correct?

    Is this machine new to you?

    What is the service history?

  4. #4
    Quote Originally Posted by K447 View Post
    You are starting a machine that has sat for six months, correct?

    Is this machine new to you?

    What is the service history?
    Hi, sorry maybe o was a little vague on info, it was my dads ski so know the service history etc it just hasn't been used I went round tonight put fresh fuel in and some easy start, and with the choke out I managed to after a while to get it to fire, I'm just struggling to keep it running.

    Wether this is down to the engine not warm enough with choke etc or a little dead fuel. The plugs aren't in great condition but did get it to start and run for about 5-10 seconds. Then the battery went flat after trying to start it for a long time. My new plugs should arrive tomorrow. And hopefully it should have pulled some fuel through now.

    As as I said before the the ski would really idle great if at all so is there any adjustment on this? Appreciate your help

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,382
    +1
    1,745
    Did you drain out the old fuel or just add fresh gasoline to the tank?

    Old fuel can cause problems.

    Clogged up carburetors will often not run right until internally cleaned and rebuilt.

    These engines really, really want the entire fuel system to be 100% good.

    Clean fresh fuel, new fuel hoses, new fuel filter, new fuel selector valve.

    And clean rebuilt carbs with genuine OEM carb rebuild kits.

    Correct spark plugs are important.

    what year and model is this machine?

    Click my signature links for lots more useful info.

  6. #6
    Update,

    ive got it running and it sounds great, now I have three questions.

    theres a bit of blue smoke coming out from under the seat nothing to excessive just X a bit what's this from?

    It it doesn't idle at all, it sits at low throttle okay just not idling, how to I adjust this? Has anyone got a photo of the screw needed.


    Also the old plugs where black! How do I adjust the mixture as at the moment I have oil tank and a petrol tank. Separate.


    appreciate your help.

    Jack


    As as for the year I'm not to sure it looks like it has triple carbs and it's a red engine.

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,382
    +1
    1,745
    Quote Originally Posted by Jackprangnell View Post
    Update,

    ive got it running and it sounds great, now I have three questions.

    theres a bit of blue smoke coming out from under the seat nothing to excessive just X a bit what's this from?

    It it doesn't idle at all, it sits at low throttle okay just not idling, how to I adjust this? Has anyone got a photo of the screw needed.


    Also the old plugs where black! How do I adjust the mixture as at the moment I have oil tank and a petrol tank. Separate.


    appreciate your help.

    Jack


    As as for the year I'm not to sure it looks like it has triple carbs and it's a red engine.
    Last two digits from HIN number plate on rear deck are the model year.

    Sounds great doesn't matter if it does not run properly. Getting it running is not the goal. Getting it running properly and making sure the entire watercraft will be reliable is the requirement. Otherwise you are at high risk of possible engine damage, stranding on the water, even possible sinking or personal injury.

    Exhaust smoke coming from under the seat must be located and corrected. There should be zero exhaust leaks inside the hull. Check every exhaust hose for damage, soft areas, loose clamps, etc.

    If any of the exhaust hoses show signs of overheating, internal heat blistering or internal delamination, check the exhaust water injection screen and orifice. In fact, check it regardless.

    Have you looked through my signature links? If not, do so.

    Did you do all the work listed in my previous post?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How-To: Oil Change
    By Sunfunzoom in forum Sea Doo How To & FAQs
    Replies: 280
    Last Post: 06-28-2017, 08:34 PM
  2. Instruction on how to remove intercooler Newbie help 310R 2015
    By 310RBasingstokeuk in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 12-14-2015, 06:28 PM
  3. Question on how to get the best price for a SeaDoo; please help a newbie :-)
    By Merovinchian in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 11-05-2014, 10:00 AM
  4. Newbie question: How to check water screen on SLX 1050?
    By scooby50021 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-18-2013, 09:05 AM
  5. newbie how to...perform a prepurchase inspection
    By jeepnjon in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-25-2007, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •