Results 1 to 1 of 1
  1. #1

    2014 Sea Doo GTI SE 130 Low Voltage Issues

    I just bought a used 2014 Sea Doo GTI SE 130 in the middle of last month and while i was bringing the ski home i saw that there was a low voltage notification. i thought it was because of the ski being in storage for a year. there were only 13 hours on it so i decided to change the battery. after 2-3 hours of use i got the low voltage fault again this time with a new battery so i decided to buy a gel battery. when i changed the battery i also replaced the voltage regulator and checked the fuses which all looked good. after waiting a week to use the ski started up fine and after another 2-3 hours of use over 2 days i got the low voltage fault a third time and the battery is dying. Could it be a loose connection on the battery terminal? Thank you for your help!!!
    Last edited by MKBrown; 09-12-2016 at 08:32 PM.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Simple Solutions: 2016 Sea-Doo GTI SE 130
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 06-30-2016, 10:10 AM
  2. Sea-doo GTI SE 130 2010
    By morro23pr in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 01-16-2016, 12:46 PM
  3. Bread & Butter: 2014 Sea-Doo GTI SE 130
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 07-02-2014, 01:00 AM
  4. Sea doo GTI Se 130/155 vs kawasaki stx 15f
    By newspeed in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 08-28-2013, 04:11 PM
  5. 2007 Sea-Doo GTI SE 155
    By Flynfox in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-10-2007, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •