Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    RXPX 300 In the shop 3 times with 15hrs of use. Can I get it bought back?

    I only have 15hrs on the ski. And between 10-15hrs it's been in the shop 3 times.
    IBR fault then coolant dump and overheat and now another iBR fault.

    Each time I have to haul the ski out and trailer it to the dealer. I've spent more time doing this than riding it the past two months.

    With the ski being so new and having this many problems so soon I have lost faith in the reliability of it. I ride in the ocean typically and can be in a very difficult and possibly dangerous situation of it breaks out there. Fortunately each time it's broken it has been enroute home.

    Has as anyone been able to return one of these for a refund? I no longer am confident of this ski. I love the performance but not at the expense of having most of my time wasted taking it to the shop.


  2. #2
    Phishphan1995's Avatar
    Join Date
    Feb 2015
    Location
    IL
    Posts
    412
    +1
    59
    Depends on the lemon law for your state. But I would say it's gonna hard to get that accomplished since it's under warranty

  3. #3
    My point is a warranty is great but if the ski goes to the shop after every other outing it's just more of a hassle then it is fun.

  4. #4

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    332
    +1
    31
    What did you do to overheat it?

  5. #5
    All the coolant dumped through a hose and temperature quickly spiked, I shut it off ASAP but not before the temp reached 280 or so.

  6. #6

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    trade it in.

  7. #7
    FPV TRANNY's Avatar
    Join Date
    Mar 2015
    Location
    Gold Coast, Australia
    Posts
    247
    +1
    36
    Seems to be a bit of a trend going on here. I have ran into a couple of people in OZ that have encountered the same issues.

  8. #8

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,096
    +1
    834
    Man a simple hose clamp. You would think seadoo would be all over the dealers to check these and as a dealer you would think you would not want this issue to happen to your customer. Yet even my tx300 had the hose clamp on wrong and that was mid way through the season when I bought it. Luckily because of this forum I knew better to check/fix it before I rode it. My bud had his coolant eject on a WFO run. He Shut it down right away and towed it back, let it cool completely and it seemed fine after that. Hard to say if your engine is damaged or not....either way your dealer seems to be incompetent. There have been a few IBR getting replaced but doesn't seem to be an epidemic. If it starts acting slower than normal or gets stuck...it's probably going bad. Good luck, hang in there the px is an awesome matchine. I'm at 75 hrs no issues on mine.

  9. #9

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    332
    +1
    31
    I think a buzzer goes off if the temp goes over limits. Easy warning

  10. #10
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    780
    Quote Originally Posted by bluestram View Post
    I think a buzzer goes off if the temp goes over limits. Easy warning
    The buzzer triggers when it senses an overheat condition (230F). Not before...so its "overheated" the moment you hear it and in those situations, rapidly climbs above 230F as it only takes seconds to reach 250F or so.

    What would be nice (and easily done in software - or self add-on) is a pre-warning that triggers at 205F then full limp mode at 230F (per OEM spec).

    The biggest risk to overheating is warping the head (as with all aluminum heads). My old motor did it twice in its 260hr life and on rebuild, machinists said head was warped (was expecting that as its not too unusual anyways). Chicken or the egg....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anybody with RXP running the RXPX washer in the Pump
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-20-2009, 04:08 AM
  2. Gp1200r SUCKS, In the shop again and I am being screwed
    By neillauer in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 07-05-2006, 07:31 PM
  3. Ski in the shop
    By brad2510 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 03-24-2006, 10:06 PM
  4. Getting RXP back tomorrow after down time in the shop.
    By Jrsrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-14-2005, 09:46 AM
  5. RXP still in the shop
    By Jrsrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-10-2005, 09:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •