Results 1 to 4 of 4
  1. #1

    Join Date
    Apr 2016
    Location
    Sydney, Australia
    Posts
    89
    +1
    4

    Would this be a reason for power loss???

    Went out for a ride today fx svho for the first time since my mechanic winterised my ski.
    seemed as though I lost a lot of power so went back on the trailer and went home.

    Found that one of the injectors was not plugged in. Would this be the reason for the loss of power ?
    Last edited by Jaycee84; 09-11-2016 at 03:45 AM.


  2. #2
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,220
    +1
    1,076
    One would certainly think so..... lol.

  3. #3

    Join Date
    Apr 2016
    Location
    Sydney, Australia
    Posts
    89
    +1
    4
    Lol that's what I thought! At least it was only something small but stupid little lol

  4. #4

    Join Date
    Jan 2016
    Posts
    1,529
    +1
    306
    down 25% hahaha

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. would this be too lean???
    By bow tie klr in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 06-10-2009, 12:04 PM
  2. would this be any good for wave jumping?
    By FL03GTX in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 12-18-2008, 05:03 PM
  3. Would this be Open class legal?
    By ou812 in forum Race Events and News
    Replies: 4
    Last Post: 11-10-2008, 11:15 AM
  4. Would this be under warrenty??
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-24-2006, 07:43 AM
  5. Would this be an ok mod setup for a budget????
    By kenshin89 in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-25-2005, 07:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •