Results 1 to 4 of 4
  1. #1

    Pump neoprene seal

    Had something interesting happen today, the neoprene seal in between the wear ring and hull somehow came off and got sucked through the pump. Ended up getting stuck between the impeller and vanes. Caused a crazy amount of cavitation. Has anyone had this happen before? What could cause this?

    The Spark is still on the lift, hope to get it off tomorrow to take off the pump and replace it.


  2. #2
    Sounds to me like someone didn't put it back on correctly or somehow that rubber seal broke and got sucked off...hahaha

    My money would be on that...it wasn't installed correctly on the wear ring...but I could be wrong.
    Last edited by rew2424; 09-08-2016 at 07:08 PM.

  3. #3
    Quote Originally Posted by rew2424 View Post
    Sounds to me like someone didn't put it back on correctly or somehow that rubber seal broke and got sucked off...hahaha

    My money would be on that...it wasn't installed correctly on the wear ring...but I could be wrong.
    Yup that someone was me. Got it on a trailer and took it apart. I f'ed up putting the pump on and the bottom two bolts were missing. I either didn't tighten them all the way or didn't replace the yellow loctite. Interestingly the seal came off as I was in reverse..... Lasted 25hrs though. Need to replace the wear ring now as well since the misaligned the pump and destroyed it.

    Picking up the parts tomorrow, will install correctly and fingers crossed it fixes it! Only a few more weeks left in the season.

  4. #4
    Bummer dude..that sucks....but on the bright side at least the entire pump assembly didn't come off...those bolts are torqued to 16 ft lbs and be sure to use Blue Loctite on the bolts.
    Last edited by rew2424; 09-11-2016 at 06:50 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Was it a neoprene seal or a pump spacer?
    By DKFox in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-12-2009, 05:03 PM
  2. Stator pump shaft seals
    By scorp in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-03-2009, 09:43 PM
  3. Riva Ride Plate. Pump Shoe Seal Kit Needed??
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-16-2007, 07:15 PM
  4. Pump Shoe Seal Kit
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-04-2007, 11:44 AM
  5. pump duct seal
    By addicted in forum Yamaha Old School Skis
    Replies: 32
    Last Post: 05-03-2007, 07:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •