Results 1 to 10 of 10
  1. #1
    zapufast's Avatar
    Join Date
    Apr 2014
    Location
    Pace, FL
    Posts
    347
    +1
    62

    Has anyone experienced a pull using Jim's Plate?

    I have a right hand pull that is really annoying on long rides on my 2015 FX SVHO and I have tried measuring from hull chimes to the edge of the cutout on the ride plate and nothing helps. I have talked to Jim and gong to send it back this winter when I'm not riding, but just wondering if there is anything I can do until then...


  2. #2
    db2540's Avatar
    Join Date
    May 2009
    Location
    AUSTRALIA
    Posts
    368
    +1
    17
    Is your exit nozzle stock? Are you using the Lucky 13?

    http://www.greenhulk.net/forums/showthread.php?t=250764


  3. #3
    zapufast's Avatar
    Join Date
    Apr 2014
    Location
    Pace, FL
    Posts
    347
    +1
    62
    Stock exit nozzle and yes, lucky 13 with no washers

  4. #4
    zapufast's Avatar
    Join Date
    Apr 2014
    Location
    Pace, FL
    Posts
    347
    +1
    62
    Thanks for the link.... I will try that!

  5. #5
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,213
    +1
    544
    Did not know you were using lucky 13 i would of gave you my finding right away. I have had many lucky 13 that pull to the right the way i have cure them is remove siphoning tube and epoxy hole. And have had a couple lucky 13 were customers put wrong.


  6. #6
    Quote Originally Posted by zapufast View Post
    Stock exit nozzle and yes, lucky 13 with no washers
    It's not the plate. It's the cone.

    Also, I was faster without the cone on my FX. Testing done by Dean.

  7. +1 by:


  8. #7
    rcab85's Avatar
    Join Date
    Nov 2011
    Location
    lavalette, New Jersey, United States
    Posts
    1,597
    +1
    84
    Ouch

  9. #8
    zapufast's Avatar
    Join Date
    Apr 2014
    Location
    Pace, FL
    Posts
    347
    +1
    62
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    Did not know you were using lucky 13 i would of gave you my finding right away. I have had many lucky 13 that pull to the right the way i have cure them is remove siphoning tube and epoxy hole. And have had a couple lucky 13 were customers put wrong.
    If I totally remove the stem, what do I do with the hose? Just plug it?

    Also I like Lucky 13 because it helps with cavitation, but will go back to stock cone if can stop the pull.

  10. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,213
    +1
    544
    Quote Originally Posted by zapufast View Post
    Quote Originally Posted by JIM'S PERFORMANCE View Post
    Did not know you were using lucky 13 i would of gave you my finding right away. I have had many lucky 13 that pull to the right the way i have cure them is remove siphoning tube and epoxy hole. And have had a couple lucky 13 were customers put wrong.
    If I totally remove the stem, what do I do with the hose? Just plug it?

    Also I like Lucky 13 because it helps with cavitation, but will go back to stock cone if can stop the pull.
    I would say just to test put the factory cone back and see if it pulls before cutting anything.

  11. #10
    dennisb20's Avatar
    Join Date
    Dec 2012
    Location
    MA
    Posts
    114
    +1
    10
    Press the siphon tube out cut 1/2 to 3/4 inch off tube reinstall this should solve pulling issue. Jerry and others had said this on other posts. Jerry's plate mod has worked great on my fx sho, fx svho and son's fz svho

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Used Jim's plate GPR
    By tmg97gp in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-16-2016, 09:41 AM
  2. Has anyone gotten the new Riva grate and plate?
    By cut2please in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 07-25-2010, 09:16 PM
  3. has anyone experienced bendix bushing going bad?
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 10-04-2008, 06:02 PM
  4. Has anyone in texas been ticketed for pulling without a spotter
    By Larry L in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-01-2006, 05:10 PM
  5. Has anyone ever used their fire extinguisher?
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 03-04-2006, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •