Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28

    1996 Polaris sl 650, bogs down then runs OK for short while

    help please my Polaris was running find few days ago.now when in the water bogs down at full throttle no getting any speed out of it.then once in a while the speed picks back up and the same crap happens new to the jet ski fun and headaches.
    Last edited by K447; 09-07-2016 at 09:38 PM.


  2. #2

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28
    any one know how to test the multi function display on a 780 stl is not working

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,388
    +1
    1,745
    Unplug the MFD connector from the back of the display. Click on my signature link, look in the MFD section for info on how to remove the MFD from the handlebar pad.

    Sometimes a dead MFD can affect the engine operation.

    For MFD testing, first use a meter to verify there is battery voltage at the MFD connector. Should measure full battery voltage between the Black wire and Red/Purple wire at the connector.

    There is a glass fuse in the electrical box. If it has failed, replace only with another 1/4 amp fuse.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,388
    +1
    1,745
    Quote Originally Posted by lopezh View Post
    help please my Polaris was running find few days ago.now when in the water bogs down at full throttle no getting any speed out of it. then once in a while the speed picks back up and the same crap happens new to the jet ski fun and headaches.
    What model year is your SL650?

    What is the service history on this machine?

    Have the carburetors been rebuilt in recent memory?

    Has the rest of the fuel system been maintained?

  5. +1 by:


  6. #5

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28
    there's a fuse but is a 25 amp glass fuse someone put a wrong one in, will that affect it?

  7. #6

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28
    not really sure just bought it from a guy who had it in storage for six month.took out ran fine then a few days later took out and it would at like there was not enough fuel and no power at all then at times it would come back for a few minutes.notice the thermostat sensor was broken but it ran fine with it like that.

  8. #7

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28
    96 sl 650

  9. #8

    Join Date
    Sep 2016
    Location
    raymond maine
    Posts
    28
    where can i find parts like the harness for Polaris650 sl skis

  10. #9
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,388
    +1
    1,745
    Quote Originally Posted by lopezh View Post
    not really sure just bought it from a guy who had it in storage for six month.took out ran fine then a few days later took out and it would at like there was not enough fuel and no power at all then at times it would come back for a few minutes.notice the thermostat sensor was broken but it ran fine with it like that.
    I suggest you need to do a methodical process. It is common for these older watercraft to need servicing and maintenance work done.

    What is not a good idea is to ride it until you know that it is ready for the water. It is easy for a problem with the carburetors or fuel system to result in engine damage if the machine is ridden.

    Click my signature link, then read up on the recommended maintenance and common upgrades.

    i would expect the fuel system to need going through from end to end, fuel tank to carbs and everything in between. New fuel hoses, new fuel filter, new fuel selector valve. Rebuild the carburetors with genuine OEM Mikuni rebuild kits.

    Also consider upgrading the fuel pump.

    Spark plug wires may need to be trimmed back.

  11. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,388
    +1
    1,745
    Quote Originally Posted by lopezh View Post
    there's a fuse but is a 25 amp glass fuse someone put a wrong one in, will that affect it?
    25 amp is a huge fuse rating. It will not protect anything should a short circuit occur or the battery is connected backwards.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1992 Polaris SL 650 overheating
    By chazdo2 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-13-2008, 07:13 AM
  2. WTB: Polaris SL 650 PISTON, WITH RINGS.
    By ZOMGVTEK in forum Polaris Classifieds
    Replies: 2
    Last Post: 07-05-2008, 11:48 AM
  3. Polaris Sl-650
    By Mach-1 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 06-22-2008, 08:25 AM
  4. Polaris SL 650 triple 11992 Wont start
    By mardinero in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-03-2008, 08:29 PM
  5. WTB: 3 Outlet Fuel Pump For Polaris SL 650
    By ZOMGVTEK in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-02-2008, 04:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •