Results 1 to 6 of 6
  1. #1

    coolant leak at full throttle

    Hello
    good afternoon
    There is a coolant leak and it occurs only at full throttle (full speed) after that i saw a reservoir empty and in my jetski screen there is a code P1116
    and i noticed a small crack in cylinder head and the location of the crack is shown in the attachments .
    I don't know what to do
    Is it possible to fix this crack or should i buy a used cylinder head?
    Also my jetski rpm is 8100-8200,
    Is it possible to have the same rpm if i changed the cylinder head ?
    my jetski is RXPX 2010 255 with 300 hrs
    thank you
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	s-l16001.jpg 
Views:	124 
Size:	112.6 KB 
ID:	397745  
    Last edited by muhannad_x; 09-01-2016 at 06:13 AM.


  2. #2
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    615
    +1
    7
    the Code you saw is normal when the ski over heats...you probably had an alarm going off when you saw that pop up. If it was me, id find a different head, there is probably one on here in the classifieds. I dont see why you wouldnt run the same RPM's once the motor is repaired.

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,648
    +1
    507
    I would try to weld that spot
    bet its just a bad casting

  4. #4

    Join Date
    Jan 2016
    Location
    UK
    Posts
    238
    +1
    47
    They can be repaired by welding but it may need machining again after as they can warp slightly. Personally I would change the head.

  5. #5
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,513
    +1
    88
    Weld it,or drill and tap a thread for stainless npt blank.

  6. #6
    russ_young's Avatar
    Join Date
    Dec 2016
    Location
    Seychelles
    Posts
    8
    Hey guys, I need help, I own a rxpx 260 and the last time I used it the coolant was almost below its minimum mark after a days use. I had not seen the problem until after I had finished the day. Coolant at the bottom of the hull but no idea where it is leaking from. Engine did not overheat and have no error codes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SL700 bogs at full throttle
    By Nik33615 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-30-2008, 01:30 AM
  2. 1997 Polaris 780 SLT (Cutting out at full throttle)
    By harleyfun1996 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-24-2008, 01:02 PM
  3. 00 gp1200 stuck at full throttle?
    By felixx in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 12-22-2007, 12:22 AM
  4. Range of 250X at full throttle?
    By Socaloffshore in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-11-2007, 10:29 PM
  5. HELP!! my 2004 rxp had low the RPM's at full throttle
    By rafyrxp in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-17-2006, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •