Results 1 to 8 of 8
  1. #1

    Very bad Cavitation!!!

    I replaced the impeller wear ring housing for a friend on his Yamaha fx1000 because it had seized over the winter. Took the ski out to test it and it won't go more than 10mph. Within 5 minutes it was blowing steam and overheating. Took the pump back off and took some pictures. See anything that could be causing the cavitation in these photos?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	84 
Size:	123.4 KB 
ID:	397554   Click image for larger version. 

Name:	image.jpg 
Views:	71 
Size:	78.9 KB 
ID:	397555   Click image for larger version. 

Name:	image.jpg 
Views:	84 
Size:	91.0 KB 
ID:	397556   Click image for larger version. 

Name:	image.jpg 
Views:	76 
Size:	103.2 KB 
ID:	397557   Click image for larger version. 

Name:	image.jpg 
Views:	64 
Size:	65.9 KB 
ID:	397558  


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    992
    The bottle of mayonnaise around the mating surface doesn't help things.

  3. #3
    We used silicon to seal it.

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    992
    I see that. Your cavitation is coming from the huge gobs of silicon protruding up into the tunnel.

  5. +1 by:


  6. #5
    Hehe, I will see if that fixes it. Thanks, and pardon my ignorance.

  7. #6
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,251
    +1
    992
    Quote Originally Posted by Stx90O View Post
    Hehe, I will see if that fixes it. Thanks, and pardon my ignorance.
    The transition from the grate all the way through the tunnel needs to be extremely smooth.

  8. #7
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,733
    +1
    169
    Scrape all that out so you have a clean mating surface. If you're going to seal it, just put a light coat on...not enough to squeeze out.

  9. #8
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,733
    +1
    169
    And make sure you get it out of that cooling hole, too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad cavitation issue. Any ideas?
    By Promod1955 in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-18-2009, 06:26 PM
  2. Bad Cavitation!!! Need Help!!
    By ArmyRXP in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-08-2008, 07:46 PM
  3. I use to have a very bad hole shot
    By rlloyd in forum Sea Doo Sport Boats
    Replies: 6
    Last Post: 04-13-2008, 05:45 PM
  4. Very Bad things come in pairs
    By Region8Ultra250X in forum Videos & Pictures
    Replies: 7
    Last Post: 12-23-2007, 08:11 PM
  5. Very BAD day with the RXP Delaminated hull
    By yellow4 in forum 4-Tec Performance
    Replies: 52
    Last Post: 06-17-2007, 12:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •