Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    615
    +1
    7

    Help please 08 rxpx - hull full of oil

    I recently had everything from where the drive shaft connects to the motor and back replaced due to poor alignment. Last week while riding the thermostat/water pump came apart. No coolant in the oil and no loss of oil. I repaired that by putting a clamp around the collar on the housing. Today while giving it test ride the ski overheated in about 20 mins, back out of the water there is zero oil on the stick (was right in the middle of the bend before i left) and the hull is full of oil. All of the coolant is gone again but was boiling in the reservoir when the ski first over heated and pissing out the bleeder hose. trying to figure out where the oil is coming from now, there seems to be oil in the pump as the nozzle is covered in oil. Stage 1, 144 hours on it.

    Got a P1116 error but i know that is from overheating.

    Head gasket?
    Motor toast?
    something not put back together properly?
    Supercharger related? has 20 hours on it but was just inspected.

    Need to know anything else?


  2. #2
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    3,286
    +1
    1,940
    If bubbling in reservoir I'd suspect a head gasket. Oil loss could be one of new parts failing where drive shaft meets engine.

  3. #3
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    615
    +1
    7
    to add when i pulled the plugs, the 2nd and 3rd cylinders plugs were covered in oil

  4. #4
    Banned User
    Join Date
    Nov 2014
    Posts
    200
    +1
    13
    Solution, get a few sockets, wrenches and start parting it out. You might make enough money to put a deposit on another ride...

  5. #5
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    615
    +1
    7
    Quote Originally Posted by JeffStalone View Post
    Solution, get a few sockets, wrenches and start parting it out. You might make enough money to put a deposit on another ride...
    why do you say that?

  6. #6
    Having the same problem with my 255, engine overheat and coolant issue. Had compression test done and cylinder 1 & 2 had low compression..... Said the hell with it and just bought a 16' RXT 260 this weekend. Been wanting a smoother ride anyway...

  7. #7
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    3,286
    +1
    1,940
    If you feel comfortable start tearing it down--but buy a manual so you know what to do.

  8. #8
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    615
    +1
    7
    Quote Originally Posted by Mothman View Post
    If you feel comfortable start tearing it down--but buy a manual so you know what to do.
    Might come to that. First I'm contacting the shop that did the driveshaft work and letting them take a look.

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,341
    +1
    261
    Maybe two problems at once.

    1 They pulled the PTO bearing out when they pulled the driveshaft. Thats that is the oil leak.

    You can pulled the PTO bearing back out(pull driveshaft back out).. Push the sleeve back into the bearing. I clean the bearing and boot with brake clean and seal with Ultra Black RTV and a new clamp.

    2 You still had air in the coolant system. Causing the overheat. It can be hard to get the coolant system flushed of air the way the hoses to rideplate are ran.

  10. #10
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,341
    +1
    261
    Oh about the oily plugs. SD had a problem with the "X" engines piston rings that year. Is the that original engine never rebuilt it may have the ring problem.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My maiden voyage left me with a hull full of water. (96 XP)
    By JJLee138 in forum Sea Doo Open Discussion
    Replies: 29
    Last Post: 03-20-2013, 12:32 AM
  2. Hull full of oil-inconsistent oil leak
    By linden in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-17-2012, 04:24 PM
  3. Fuji - crank cases full of oil
    By bgaidan in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-29-2010, 08:31 PM
  4. HELP PLEASE how to check jet drive oil
    By Hands in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-25-2009, 08:06 PM
  5. Ultra 150 hull full of water?
    By lkn ultra in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 04-25-2008, 09:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •