Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    1999 SLTX Accelerator pump problems.

    I know this has been covered many times but I would like some clarification. My !999 SLTX has overhauled carbs (oem parts) but darned if I can't get the accelerator pump to work well. What is the correct way to prime this pump? Engine running or stopped? Are there non-return valves in the pump that fail? Are there non return valves in the accel pump jets that gum up? It seems that the accel pump on the triple CDK II carb set up is a critical component and if it is not pumping properly the ski will bog badly. Last time I looked no parts were available for the accel pump has that changed?
    Can I rejet the carbs and do away with the confounded accel pump?


  2. #2
    OK I'll try that.

  3. #3
    I have been going through the same thing with my with my 2001 virage tx. Would run great higher rpms, but a dog off idle. Had to give a blip of choke from idle and then fine. If I manually pressed in pump rod, it would squirt fuel and be fine. With the throttle it would not work. It looked like my accelerator pump rod was worn so not pushing in far enough. Could not find parts so a machinest friend of mine made a longer rod, not by much, and was able to install in diaphragm without destroying. It seems to be working properly on trailer, where I still had same problem of bog and dying off idle before. Now, from idle to wot no problem, no bog, no hesitation, no feathering throttle. Seems to be fine. Will be going to lake today and hopefully the same. I also adjusted my needle arm heights at same time I installed new pump rod. Not sure if that had something to do with it.

  4. #4
    Just got back from lake. It ran great. Shot out of hole like a rocket. The new pump rod a little longer seemed to make a world of difference. I also reset the arm heights when I did the pump rod to make sure they were correct. I am by no means an expert. Just letting you know what worked for me. I hope it helps.

  5. #5
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,815
    +1
    52
    Quote Originally Posted by Britpilot View Post
    I know this has been covered many times but I would like some clarification. My !999 SLTX has overhauled carbs (oem parts) but darned if I can't get the accelerator pump to work well. What is the correct way to prime this pump? Engine running or stopped? Are there non-return valves in the pump that fail? Are there non return valves in the accel pump jets that gum up? It seems that the accel pump on the triple CDK II carb set up is a critical component and if it is not pumping properly the ski will bog badly. Last time I looked no parts were available for the accel pump has that changed?
    Can I rejet the carbs and do away with the confounded accel pump?
    From I understand. There are check balls at all 3 accel pump nozzles (1 in each carb) and a check ball in the jet block near the accel pump.

    When the throttle is squeezed, pressure unseats the check balls in the nozzels,but seats the pump check ball. When the throttle is released, the check balls at nozzles close-creating a suction in the hoses-that suction along with some fuel pressure unseats the check ball at the pump-allowing fuel into the pump.

    The pump rod rides on a plastic cam,it's not a very long stroke on the rod.It's possible for the cam to wear- I beleive the 700 carb pumps might have used a larger cam. Of course, cycling the pump manually causes a longer stroke on the pump rod, creating a longer pump cycle to help allow the pump/check balls to work.

    I have seen the nozzles gum up and those check balls to not seal or not unseat. It is also possible for the other check ball at the pump to not seat. TXpro1200 has a write up for replacing the check ball at the pump.

  6. #6
    OK Thanks Guys!

  7. #7
    Reset the arm heights? No sure what you are talking about here. Please explain further.

  8. #8
    Do you have a link to the write up by TXpro1200 that you mention?

  9. #9
    Tx pro and casey too I believe had suggested I set arm heights in carbs...the height of the arm that hold the needle....the end opposite that holds the needle...behind the screw that holds it down has a plastic button on it....there are specs as to how much clearance there should be by ween that button and top bottoman of block cover...evidently these heights being off would result in too much or too little fuel so they felt this needed to be done as part of carb rebuilding....I did it when I replaced pump rod as I didnt know about it when I rebuilt carbs. ..all settings were off a little from spec..
    .060 for my carbs....txpro had suggested I replace the ball in ghế metering block....because when I cycled the pump rod by hand I got good fuel through the 3 nozzles and my pump rod looked worn and like it wasnt making good contact withe the cam....I decided to lengthen the pump rod as this was easier to try first versus replacing the check ball 9n the metering block....I tested before replacing the rod by rigging a shim...I used a muzzle loader cap...on the end if the rod and ran on hose. .
    Until it fell off it worked whích led me to the conclusion that the rod was too short...or the cam was worn or both. ..iny case it was easier to replace with longer rod....and it worked great....I would cycle pump manually...I think if you get fuel like that you can eliminate check ball and gumming as problems....but I not an expert...only going by my experience.

  10. #10
    Just rẻ read. Sorry for some misspellings and extra or missing words...if u dnt understand kết me know

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do you recommend my solition? Accelerator pump problem
    By Kory70 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-20-2012, 05:22 PM
  2. 1999 GXT Jet Pump problem
    By jsl750&slt750 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-14-2010, 10:33 PM
  3. 1999 X-45 SLTX-b Pump Rattle
    By Syclone in forum Polaris Open Discussion
    Replies: 18
    Last Post: 06-03-2008, 08:18 PM
  4. Will a 1996 SLTX Jet Pump fit a 1999 1050 SLTX?
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-24-2007, 09:28 AM
  5. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •