Results 1 to 6 of 6
  1. #1

    rxtx 260 2010 temp light turn on and check engine when woot

    hello guys
    i have a rxtx 2010 and when i press full gas trigger and run like 8 seconds at woot the temp light turn on also the check engine light
    any help?
    thank you
    Last edited by user83; 06-28-2016 at 12:27 AM.


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,397
    +1
    881
    Check the exhaust manifold cooling hoses and make sure they are free of debris as this debris (most time sand)can cause less waterflow in the exhaust making the high temp go off and put ski in limp mode.

  3. #3
    ok i will check today,
    anyway to see the fault code my self without scanner?

  4. #4
    is this the host i has to clean? looks clean inside
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20160628_004657.jpg 
Views:	30 
Size:	48.2 KB 
ID:	392093  

  5. #5
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,670
    +1
    512
    run it on the hose for about 1 min
    that will back wash your manifold
    check exhaust sensor, they melt when over heated

  6. #6
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,149
    +1
    812
    The first hose to check is the hose from the pump to the iBr thru hull fitting. On 2010's it is VERY COMMON for them to split and the hose was redesigned and strengthened.

    Raise the Ibr gate per the Owners Manual procedure and remove the 2 small hose clamps and inspect closely. The is the source for all water into the ski for cooling! If this one is good, you have a leak somewhere in the system, most probably a loose hose clamp.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1340.jpg 
Views:	117 
Size:	45.2 KB 
ID:	392113  

  7. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-23-2019, 12:28 AM
  2. Yamaha GP1200R problem with no Spark and water temp light comes on?
    By Quottro in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 07-26-2015, 05:04 AM
  3. Unlock light coming on and wierd beeeeeep sound!!help
    By fxho in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-23-2009, 09:15 PM
  4. RXP stage II H Temp light coming on
    By MIARider in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-23-2007, 11:42 PM
  5. RXP stage II H Temp light coming on PART II
    By MIARider in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-16-2007, 01:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •