Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    844
    +1
    61

    2016 Yamaha - timing chain issue or problem solved?

    hi men...
    many 2016 yamaha stock or modded on the water...
    but really zero timing chain issue?
    I've never heard of that for now.
    the new chain (and related mods) seems work very good!!


  2. #2
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,351
    +1
    543
    Believe me if there was an issue there would 100 threads on it by now asking the same question.

  3. +1 by:

    Ale

  4. #3
    Ale's Avatar
    Join Date
    Feb 2014
    Location
    ITALY
    Posts
    844
    +1
    61
    yes... seems that new chain solved the problem!!

  5. #4
    Chupacobra's Avatar
    Join Date
    Jun 2012
    Location
    Orlando, FL
    Posts
    1,410
    +1
    423
    I haven't seen much more chain breaking period.. must of been something in the air lol

  6. +1 by:


  7. #5

    Join Date
    Mar 2010
    Location
    the moon
    Posts
    862
    +1
    19
    I hope it is fixed I just purchased a brand new 2016 fzr.

  8. #6
    Banned User
    Join Date
    Sep 2014
    Posts
    1,150
    +1
    130
    dont believe everything you read on the internet. There was no issue with 14-15 skis. It's really easy for keyboard commandos to type they had a broken chain on here, but out of all the claims of broken chains ive yet to even see one picture.

    I'm not saying zero broke, but Yamaha said it was less than 1%. They're not lying.

  9. #7
    gp1200rider's Avatar
    Join Date
    Mar 2008
    Location
    MD
    Posts
    1,016
    +1
    50
    here's mine. 14 fzr
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2016-06-08 18.40.46.jpg 
Views:	1640 
Size:	48.0 KB 
ID:	391413  

  10. #8
    Banned User
    Join Date
    Sep 2014
    Posts
    1,150
    +1
    130
    Well, you caught it before it broke. That's an easy warranty fix

  11. #9
    incognito's Avatar
    Join Date
    Jul 2015
    Location
    South Florida
    Posts
    805
    +1
    80
    Gp 1200,that pic of chain from a 14/15 SVHO??

  12. #10
    Banned User
    Join Date
    Sep 2014
    Posts
    1,150
    +1
    130
    2009-2015 SHO/SVHO use the same timing chain. Still used in the 16 SHO.


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kit to fix the timing chain issue
    By JIM'S PERFORMANCE in forum Yamaha PWC Performance (4-stroke)
    Replies: 70
    Last Post: 12-04-2019, 03:17 PM
  2. 2014 svho timing chain issues
    By JDELFINO in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 09-29-2018, 05:16 AM
  3. Timing chain issue?
    By Leendert in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-24-2015, 09:39 AM
  4. To all the people with timing chain issues ..look inside...
    By vvinmann in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 07-17-2015, 06:27 AM
  5. cam gear won't on / timing chain issue
    By imp0ster in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-07-2013, 07:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •