Results 1 to 8 of 8
  1. #1

    2004 Polaris Virage I

    I have a '04 Polaris Virage I that I bought off CrankyApe last summer. I've been having it serviced for a year, and it still doesn't run. I live in Winnipeg, MB, Canada and Polaris will not service it here, and no one has digital wrench to diagnose the issue. I've had the fuel pump and start/stop module changed. Now my guy thinks its the EMM/ECU and an issue with the fuel injectors. Does anyone know where I could get a Polaris serviced in ND or MN? I'm in Minneapolis often, so could take it somewhere to get it worked on by a Polaris rep.
    ALTERNATIVELY, does any one need parts from this machine?
    Thanks if anyone can provide some advice.
    Steve


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,661
    +1
    2,346
    Well, there are some basic diagnostics you can do. Often this is enough to determine what the most likely problem cause is.

    Digital Wrench is not needed in many cases.

    Are you able to do basic tests with a multi-meter?

  3. #3
    Yes. What would you suggest? I had it in with a service guy who owns a shop, and he couldn't figure out the issues. We replaced the fuel pump and start/stop module. It runs but then shuts down. He thought that it was a mismatch with the fuel injectors and emm. He indicated that his next step would be to put it on digital wrench for diagnosis.

  4. #4

    Join Date
    Sep 2012
    Location
    Decatur, TX
    Posts
    180
    +1
    2
    I would pull the EMM and injectors and send for diagnostics from DFI Technologies and stop guessing. My 2 cents

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,661
    +1
    2,346
    Quote Originally Posted by skijenn View Post
    Yes. What would you suggest? I had it in with a service guy who owns a shop, and he couldn't figure out the issues. We replaced the fuel pump and start/stop module. It runs but then shuts down. He thought that it was a mismatch with the fuel injectors and emm. He indicated that his next step would be to put it on digital wrench for diagnosis.
    What are the current trouble symptoms?

    Does it have spark?

    Connect a DC volmeter red probe to a White/Red wire. Do not unplug a fuel injector for this test, find another place to tap into the White/Red wiring. Black meter probe to engine ground.

    Crank engine and monitor the voltage. It should jump up to slightly over 20 volts while cranking. If the engine starts the voltage jumps again to around 45 volts.

  6. #6
    I have worked on the ski a little in the past few weeks. I had to put the flywheel cover back on and reinstall the oil pump. I believe i connected the hoses correctly, following the service manual. I tried bleeding it and oil came out. It cranks over and starts briefly, but then cuts out with lots of smoke from the exhaust. The oil pump light is blinking constantly while starting. I haven't got the cranking voltage, but it seems like it starts and has spark.

  7. #7
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,405
    +1
    150
    Ouch, it sounds like it has been "over worked upon" by guess and by gosh rather than a methodical plan.

    I'm in Brainerd MN and I presently own 8 Virage Is, a mix of 2003 and 2004s. I could take a look at it for you over the winter, but I couldn't do anything with it this summer. I'd also be interested in purchasing it for parts.

    I do have DW, a spare EMM, and one with collision damage I can swap parts from.

  8. #8
    Martincom, I would definitely be interested in having you take a look at it. I would also consider selling it if you are interested, this is now my 3rd ski which i don't really need anymore. I had purchased it off Crankyape last summer, but had a very difficult time getting it running, and there is VERY limited (aka No) support in Winnipeg or the area. I come down to Minneapolis a few times in the summer and fall. Maybe I could bring it and deliver it to you. I would need my trailer back though for my two other units. I can send you some pics if you are interested in purchasing it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need picture and location of computer on 2004 Polaris Virage II 800
    By skeeterboy in forum Polaris Open Discussion
    Replies: 5
    Last Post: 10-05-2012, 11:26 AM
  2. 2004 Polaris Virage rollover
    By jeffreyb in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-05-2009, 11:36 PM
  3. 2004 Polaris Virage display dead won't start
    By jeffreyb in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-27-2009, 10:47 PM
  4. 2004 Polaris Virage will start now but need module
    By jeffreyb in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-16-2009, 04:28 PM
  5. 2004 Polaris virage 1
    By larryndog in forum Polaris Open Discussion
    Replies: 2
    Last Post: 02-24-2007, 02:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •