Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Dirty exhaust

  1. #1

    Dirty exhaust

    So started looking into why I couldn't achieve x charger like speeds on my 07 when I noticed in my exhaust manifold a ton of white spots inside. I'm assuming this is from leaking coolant? So what kind of repair am I looking at? Pop the head and replace gasket? Or would using that coolant leak stop work well enough to fix the issue?


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,772
    +1
    924
    Is this a salt water ski?

    Quote Originally Posted by mbaseball301 View Post
    So started looking into why I couldn't achieve x charger like speeds on my 07 when I noticed in my exhaust manifold a ton of white spots inside. I'm assuming this is from leaking coolant? So what kind of repair am I looking at? Pop the head and replace gasket? Or would using that coolant leak stop work well enough to fix the issue?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,587
    +1
    2,975
    Can you post pics for us to see?
    im willing to bet those white spots are just normal corrosion from condensation due to the wet exhaust on these skis.

    dont ever use that stop leak stuff on your Seadoo.

  4. #4
    mbaseball3's Avatar
    Join Date
    Jun 2007
    Location
    stockton, ca
    Posts
    750
    +1
    29
    This is the white residue thats bothersome. I only figured coolant was the issue since last time out it seemed that coolant kept disappearing.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG2724.jpg 
Views:	68 
Size:	50.2 KB 
ID:	381882  

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,587
    +1
    2,975
    That's actually normal to find in the exhaust. It's just slight corrosion caused by moisture in the exhaust system. If your coolant is disappearing though then you do have an issue.


  6. #6
    mbaseball3's Avatar
    Join Date
    Jun 2007
    Location
    stockton, ca
    Posts
    750
    +1
    29
    Okie dokie. That makes me feel a bit better. Thanks Jerry. Now on to figuring out the loss of speed issue.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,587
    +1
    2,975
    How many RPM is the engine running?

    Have you done a compression check yet?

    When is the last time you replaced spark plugs? Wear ring?

  8. #8
    wkuadam07's Avatar
    Join Date
    Feb 2013
    Location
    Bowling Green, KY
    Posts
    1,397
    +1
    172
    Checked your oil for that missing coolant yet? Oil is always the first place i look for missing coolant...

  9. #9
    mbaseball3's Avatar
    Join Date
    Jun 2007
    Location
    stockton, ca
    Posts
    750
    +1
    29
    Only got to about 50mph 5k rpms? Haven't done compression check. Replaced spark plugs before last ride and oil change. Wear ring have not changed either but do have small grooves but cavitation didn't seem that bad? And 15/20 rides tight within ring. Took supercharger off last night and retorqued to 12ish foot pounds (dial torque wrench). And will definitely drain oil.

  10. #10
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    864
    +1
    97
    Quote Originally Posted by mbaseball3 View Post
    Only got to about 50mph 5k rpms? Haven't done compression check. Replaced spark plugs before last ride and oil change. Wear ring have not changed either but do have small grooves but cavitation didn't seem that bad? And 15/20 rides tight within ring. Took supercharger off last night and retorqued to 12ish foot pounds (dial torque wrench). And will definitely drain oil.
    Re-torqued or slip was at 12lbs??? You don't just tighten the nut more to make more slip.

  11. +1 by:


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva's Thru hull exhaust!
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 21
    Last Post: 06-25-2005, 11:08 AM
  2. Exhaust hose/plastic???
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-21-2005, 11:22 AM
  3. PPG Free Flow Exhaust
    By RXP19 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-14-2005, 10:07 AM
  4. What happ w/ Billet Exhaust Manifold?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-12-2005, 07:35 PM
  5. Exhaust manifold / header
    By Vern in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-08-2005, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •