Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    MSX150 reduced top speed

    First of all I would like to say thanks for excepting me, I have been following most msx150 posts since I purchased mine this time last year and well I couldn't ask a better bunch of people. As this is my first ever jet ski my knowledge is minimal to say the least. Since I purchased this ski I've had nothing but issues and ongoing headaches but slowly I am narrowing the list down. My issue with the ski at the moment is that I'm getting about 80kph at 7600rpm and no more and this is on a nice glassy day(no wind). I have good clean oil and not over filled, clean coolant and map sensors, I have removed and freed the frozen waste gate that it originally had but I just cant seem to get anymore out of it. I have done a compression test on the rings and found that one is at 135psi and the other is at 115 is this a contributing factor to my issues? the clearance for the impeller is about .70mm and the manual states it should be .50mm I'm sure this doesn't help the situation? I'm starting to think it might be a issue with the ETB?

    Unfortunately where I live there aren't any jet ski mechanics (good ones) and as I'm from Oz no one wants to touch an import I'm sure It's because they have no idea so I have to rely on you guys to get me through because the last thing I want to do is flog off the ski to get another one.

    Cheers guys and any info would be great.


  2. #2
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,260
    +1
    1,106
    Welcome aboard!!!! While I know absolutely zero about the 150's, give these guys time to wake up and get going and I'm sure the 150 gurus will chime in. Especially now. There's a small gaggle of guys really going to town and upping their 150 knowledge as of late.

  3. #3
    Mike Greenwood's Avatar
    Join Date
    Jun 2015
    Location
    Tulsa, Oklahoma
    Posts
    704
    +1
    57
    Ski is running 7600 without issues other than reduced speed? I would suspect a pump issue is correct. The reduced compression #s are not helping either. But losing 20 psi in a single cylinder bank may be room for concern in itself.

    Were you getting more on the big end at some point (RPMs)?
    please advise

  4. #4
    Thanks for the quick reply guys. When I first took the ski out I was getting no more than 65kph @6500rpm and after the changes I did i.e. waste gate, oil and coolant change and cleaning of the sensors which weren't to bad I've been able to get another 1200rpm out of it and mind you it got up there a lot quicker than before. I'm not sure if this is helps Mike?

    I will defiantly check the pump thanks.

  5. #5
    Cheers CrazyA

  6. #6
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,879
    +1
    224
    Are you measuring speed using a GPS? Or are you reporting the speed that the display shows? Regardless, 7600RPM is pretty high for a stock machine, so I also suspect the pump. The bad compression is very bad news as well, you most likely are in for an engine rebuild in the very near future

  7. +1 by:


  8. #7
    Thanks HiPeRcO, no GPS used just went off the dash. My friend has a polaris 140? and he took mine out for a test and said that it's got no top end. He's getting 65- 70 mph out of his. Again I'll check the pump, Thanks.

  9. #8
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,879
    +1
    224
    The speed wheel could be giving a bad reading, a gps reading is best. But again, the pump is highly suspect as well given the RPM's you are seeing. Put the machine on the trailer and look underneath, around and through the intake grate with a flashlight. Look for stuff stuck in there, and/or visible damage to the pump vanes. Also look into the pump from the rear of the machine (again with it on the trailer).

  10. #9
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,608
    +1
    1,536
    I would just pull the pump and have a look at everything. My MSX 140 sucked a rock through it and bent an impeller blade. RPMs went up by about 200 and speed was down about 3 MPH with much worse acceleration.

  11. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,686
    +1
    1,916
    Quote Originally Posted by HiPeRcO View Post
    The speed wheel could be giving a bad reading, a gps reading is best. But again, the pump is highly suspect as well given the RPM's you are seeing.

    Put the machine on the trailer and look underneath, around and through the intake grate with a flashlight. Look for stuff stuck in there, and/or visible damage to the pump vanes. Also look into the pump from the rear of the machine (again with it on the trailer).
    Engine not running. Of course.

    Watercraft speedometers are notorious for being inaccurate. Some are closer to reality than others but none are trustworthy unless compared with a GPS unit showing actual speed.

    Note that even a small amount of debris stuck inside the jet pump can greatly reduce thrust. This effect is called cavitation, spinning impeller but not much thrust even with forward hull speed.

    Last edited by K447; 12-01-2015 at 12:05 AM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Stock top speeds?
    By dgmoore in forum 4-Tec Performance
    Replies: 29
    Last Post: 06-15-2016, 05:25 PM
  2. SVHO Intake grate - Stock Top Loader reducing top speed?
    By iamjcl in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-14-2015, 08:46 AM
  3. Reduces to 6,750 RPM when reaching top speed
    By OneJESUSGod in forum 4-Tec Performance
    Replies: 23
    Last Post: 10-10-2013, 09:07 PM
  4. Reduced top speed, poor fuel economy???????
    By bmanlevac in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-09-2011, 06:47 PM
  5. RXP top speeds
    By Krazy-K in forum 4-Tec Performance
    Replies: 27
    Last Post: 07-03-2005, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •