Results 1 to 5 of 5
  1. #1

    Join Date
    Oct 2013
    Location
    Adelaide S. Australia
    Posts
    15

    one to confuse a few..

    I've got a 09 seadoo gti 155 se, its sprung a massive leak at the PTO seal, while searching around on what I need and how to fix the problem, someone mentioned something about a updated drive shaft and advised me to replace my current drive shaft with the updated one. Has anyone heard of this? If so what exactly is the so called update please? I have a manual but that don't explain what I'm trying to find out and as we all know the stealerships wont tell you stuff all.
    Through the years of 08 to 2013 it seems the shaft assembly are the same on the 4techs thus skipping the years of 09 and 2010 ( 2009 -10 sea doo pwc supplement) this is where sea doo placed a large nut at the PTO but only for the 09 and 10 model 4 techs. refer to the pics, they show the different assemblies. Any info/input would be of great help. The first pic is the assembly prior to the supplement in 09 -10s , the last pic is the assembly used during the supplement. The manual diagrams ( second pic part #34 I believe shows where the nut on the PTO came in).
    Cheers.
    Click image for larger version. 

Name:	prior setup.jpg 
Views:	50 
Size:	34.7 KB 
ID:	368860Click image for larger version. 

Name:	prior assembly.jpg 
Views:	59 
Size:	84.5 KB 
ID:	368859Click image for larger version. 

Name:	driveshaft setup 09 supplement.jpg 
Views:	60 
Size:	65.9 KB 
ID:	368858Click image for larger version. 

Name:	09 155 se.jpg 
Views:	61 
Size:	39.9 KB 
ID:	368857


  2. #2
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,158
    +1
    125
    Pull the collar back, #34, and see if the C clip, #35 is there if it's missing the collar will slide forward. If it is there then check the pump bearing.

  3. #3

    Join Date
    Oct 2013
    Location
    Adelaide S. Australia
    Posts
    15
    Quote Originally Posted by canuck View Post
    Pull the collar back, #34, and see if the C clip, #35 is there if it's missing the collar will slide forward. If it is there then check the pump bearing.
    cheers canuck for the reply,
    The parts 34 ad 35 you're referring to, is actually on the previous drive shaft assembly before the 2009 2010 pwc supplement. the shaft assembly I have is the 2009 2010 supplement (refer to the second diagram and last pic with the large nut) I put the 2 different diagrams in the post due to the supplement thing causing a bit of confusion between the 2 different assemblies while I've been searching for help.
    My question is in the last pic I've placed a red arrow where I've got a massive leak at the PTO seal, I've been advised to replace my current drive shaft to a updated one when I fix the pto seal, when I asked for a reason I would have to replace my current shaft there was no answer other then the one I have was a crap design and there has been a fair bit of problems with it and nothing else said.
    I'm just not sure why I would have to replace my drive shaft other then if the end of the spline was chewed up/damaged. and what the was the update on the newer drive shaft ( if there even is one, I'm thinking someone was trying to B.S me a bit)

  4. #4
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,158
    +1
    125
    The 09 style driveshaft is known to have problems it's recommended to switch to the standard carbon ring and C clip arrangement.

    This is one thread I found post #3 has some good info.

    http://www.greenhulk.net/forums/show...009+driveshaft

  5. #5

    Join Date
    Oct 2013
    Location
    Adelaide S. Australia
    Posts
    15
    Cheers Canuck, that's exactly what I've looking for,( the reason sea doo called it a updated shaft, and what had been done to update it) spot on with info above. Now off to resource some parts.
    Thanks again man.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 gp1300 vs 2006 gp1300 which one to buy?
    By TDSTYG in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 10-31-2007, 02:15 PM
  2. To all the wives that went to Nashville a few weeks ago
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-18-2006, 04:42 PM
  3. Any one to put "Magic Touch" on Impeller?
    By Alex13 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-25-2006, 10:11 AM
  4. I'm the FIRST one to test Jerry's new 8hp 2mph Mod ! ! !
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-25-2006, 10:28 PM
  5. RXP / RXT air filter. Which one to use?
    By RXPBeast in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-11-2006, 04:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •