Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1

    Join Date
    Jul 2015
    Location
    green lane pa
    Posts
    12
    +1
    1

    04 RXP Metal in Oil Filter

    Forgot to mention in my previous post but is it normal for some metal to be in the oil filter? My oil filter was so hogged up that the ski was throwing a code for a faulty oil pressure sensor. It ended up being the oil filter was full of metal and looked very old. This occurred when i got the ski at 129 hours and I have put 10 hours on it since with no issues. Should I be worried? It turns 8100-8150ish rpms no problem and runs 69mph on gps. Starts up fine and never had an issue with ceramic washer failure. Should i tear into it of just ride it? I shouldn't have read the RXP Catastrophic Failure thread ..


  2. #2
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,317
    +1
    565
    I would be very concerned. if its not knocking im willing to bet its your thrust on the crankshaft is gone.


  3. #3
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Oil sensor?? I'd suspect a real low oil pressure problem after finding metal in the oil filter, that motor might be going south

  4. +1 by:


  5. #4

    Join Date
    Aug 2013
    Location
    Waterloo ON
    Posts
    348
    +1
    33
    Check compression and report back...may be from rust in cylinder from improper storage...rings will flake away from the rust

  6. #5
    hill160881's Avatar
    Join Date
    Jun 2014
    Location
    The delta Ca
    Posts
    2,048
    +1
    254
    Just pull it apart now and you may just need machine work. Keep going and you will grenade the engine. That is more expensive. Use a magnet to see if it's iron or non farous metals.

  7. #6

    Join Date
    Jul 2015
    Location
    green lane pa
    Posts
    12
    +1
    1
    I'll check the oil filter for more metal particles after my 10 hours of running and get a compression test and post back.

  8. #7
    I would pull that motor out like hill from Delta California posted. It's the only logical thing to do. Loose metal inside your engine means something went bad. Pull the engine now and take it apart and you might save some $$$$. Run the engine........and your looking at 4 grand + easily. Look at the bright side, you take that engine apart and now is the time to upgrade and get all the go fast goodies from Jerry's online fast parts store. I am doing the teardown on my ski soon. It's the 2004 Rxp on the avatar

  9. #8
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    I did a oil change, and the filter was filled with aluminium shavings, if you watched gold rush I found the glory hole.. I've done 2 oil changes since then (20 hrs) and nothing yet????

  10. #9
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,478
    +1
    711
    It's common to find a few tiny flakes here and there ..but that sounds excessive. Something is shedding metal, most likely not a good sign.

  11. #10
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,350
    +1
    538
    Well when it suffers catastrophic disassembly he'll know for sure.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need opinion on metal in oil filter?
    By bryanw80 in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-25-2014, 11:24 AM
  2. Metal In oil filter!! What to do now...
    By ctdarnell in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 07-31-2012, 11:46 PM
  3. metal shavings in oil filter! Advice?
    By INDY27 in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-08-2012, 07:13 AM
  4. 06 RXP metal shaving in oil filter
    By rxp127 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-05-2011, 02:55 PM
  5. metal shavings in oil filter, what to do?
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-03-2009, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •