Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    07BRPRXP's Avatar
    Join Date
    Aug 2012
    Location
    MIAMI,FL
    Posts
    626
    +1
    8

    Pump installation rxpx 260

    Ok, so I torqued my prop perfectly but I totally forgot to torque pump bolts :/ I did tighten them in a X way but did not torque. Worried if I'll have a problem I did use locktite though.. Any suggestions ? I really would hate to remove Ibr system again


  2. #2
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,354
    +1
    546
    Depends on what you say tighten is. As the old saying goes... When in doubt.

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,683
    +1
    516
    you may be able to check them using and extension
    wont be a accurate, but better than nothing

  4. #4
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    322
    i honestly never torque my pump bolts, i snug them all up until tight in an x pattern as well, not he-man tight, but wrist tight. I also do not use lock tite on them. I also have my pump out very frequently.

  5. +1 by:


  6. #5
    1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,460
    +1
    2,770
    Quote Originally Posted by 07BRPRXP View Post
    Ok, so I torqued my prop perfectly but I totally forgot to torque pump bolts :/ I did tighten them in a X way but did not torque. Worried if I'll have a problem I did use locktite though.. Any suggestions ? I really would hate to remove Ibr system again
    Get in there and re-torque those bolts......its gonna bother you until you do, like it is now! LOL.

  7. #6
    07BRPRXP's Avatar
    Join Date
    Aug 2012
    Location
    MIAMI,FL
    Posts
    626
    +1
    8
    I did tighten them wrist tight very very careful to tighten all bolts evenly so I think it will be ok regardless it's the first run this weekend from stock to beast mode with the et70-145 so I'm going to run it and see what rpm it spins with the 15/20r I have I put r&d seal with stainless wear ring so let's see I might add a lucky 13 and for sure a riva nozzle next week...

  8. #7
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    322
    if you have a stock nozzle on that thing be prepared to blow it apart.

  9. #8
    07BRPRXP's Avatar
    Join Date
    Aug 2012
    Location
    MIAMI,FL
    Posts
    626
    +1
    8
    How quick do you think it will blow? And why?

  10. #9
    07BRPRXP's Avatar
    Join Date
    Aug 2012
    Location
    MIAMI,FL
    Posts
    626
    +1
    8
    I have 2 prv installed also

  11. #10
    Branden's Avatar
    Join Date
    Aug 2014
    Location
    Cape Coral, Fl
    Posts
    1,600
    +1
    322
    you have a new rxpx correct? im judging by your picture you do. The stock nozzle castings are very weak some get away with it some dont. I blew 3 stock ones apart within 5 hours once i put a 137+4 and 68-140 on. with the x charger i never had a single issue but once you put some power to it you are at risk of blowing them. nothing really happens other than your motor will zing to the moon and its like letting off the gas real hard at speed. i finally just put my riva 84mm nozzle on my stock pump and havt had an issue all the way to 20 psi so far. when they blow they basically blow and break the top 2 ears on the nozzle and the thrust bends the nozzle down so when they break you will not be able to really get up on plane. Fortunately mine have all blown near the ramp lol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXPX 260 - Riva Fuel Pump Install Drama
    By DinoMite in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-14-2013, 09:47 PM
  2. RXPX 260 pump removal question
    By dpracing in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-04-2013, 07:29 AM
  3. 2012 RXPX 260 RS pump shoe seal problem help!
    By stiv in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-20-2013, 10:36 PM
  4. rxpx-260 cruise control installation
    By idoodou in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-21-2013, 10:11 PM
  5. rxpx 260 riva trim tab install
    By seadoo02xp in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-04-2012, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •