Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    aksor's Avatar
    Join Date
    Jun 2015
    Location
    Ottawa, Canada
    Posts
    53
    +1
    1

    94 SL750 Can't seem to get full RPM WOT

    I had this ski since April. Had to rebuild crank and replace PTO piston.

    I had the engine pressure tested after the rebuild an it is airtight, Compression is 148P 150C 148M.

    Carbs have been rebuilt and cleaned just trying to tweak the high speed needles.

    Before the rebuild I was able to hit 89Km/H@ 6200 rpm on the dreamometer, after the rebuild Im only able to hit ~76Km/H @6000 rpm for some reason at wot the rpm seems to stay at 5900-6000 rpm. on a mirror lake.

    It's not lean cause If I pull the choke it bogs.

    here are the plugs and piston wash pics quality for the piston wash is iffy as I used a boroscope.

    Let me know what you guys think. 1st pic is the Center the 2nd is the PTO and the last one is the MAG piston.

    to me the center one looks weird. almostl like it has water injestion maybe leaky head gasket? disregard the M on the piston.
    Click image for larger version. 

Name:	55C9896C.jpg 
Views:	39 
Size:	252.0 KB 
ID:	367805Click image for larger version. 

Name:	55C9899B.jpg 
Views:	30 
Size:	223.0 KB 
ID:	367806Attachment 367809
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	55C86BD3.jpg 
Views:	36 
Size:	219.5 KB 
ID:	367810  


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    5,040
    +1
    143
    I agree on the Cen - pull the head and reseal the head gasket with copper gasket spray and see how she does.... How does the dome in the head? any pitting?

  3. #3
    aksor's Avatar
    Join Date
    Jun 2015
    Location
    Ottawa, Canada
    Posts
    53
    +1
    1
    will have to take a look.

  4. #4
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    895
    +1
    21
    Center looks like physical damage almost...though too evenly distributed.

    Wash looks OK to me. I actually have my skis detuned to about 6100RPM for safety.

  5. #5
    aksor's Avatar
    Join Date
    Jun 2015
    Location
    Ottawa, Canada
    Posts
    53
    +1
    1
    the image quality is pretty crappy and what looks like pitting on the piston is actual pixelization it does not look pitted and no piston damage is visible, the more I think about it I think it's getting steam cleaned.

  6. #6
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,479
    +1
    186
    Quote Originally Posted by stimpsonjcat View Post
    Center looks like physical damage almost...though too evenly distributed.

    Wash looks OK to me. I actually have my skis detuned to about 6100RPM for safety.
    How do you detune? Changing the impeller? Over rich-ing on the top end? Wrap a bunch of ducktape around handlebar behind throttle trigger?

    Cheers!

  7. #7
    aksor's Avatar
    Join Date
    Jun 2015
    Location
    Ottawa, Canada
    Posts
    53
    +1
    1
    lol he means rich-ing it up I suppose.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    5,040
    +1
    143
    Quote Originally Posted by ripcuda View Post
    Quote Originally Posted by stimpsonjcat View Post
    Center looks like physical damage almost...though too evenly distributed.

    Wash looks OK to me. I actually have my skis detuned to about 6100RPM for safety.
    Wrap a bunch of ducktape around handlebar behind throttle trigger?

    Cheers!

  9. #9
    I'D RATHER SWEAT THAN SHIVER hyoctane23's Avatar
    Join Date
    May 2007
    Posts
    2,085
    +1
    47
    Make sure you have no exhaust leaks. Try running with the seat off or at least cracked open to see if you gain any RPMs.

  10. #10
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    895
    +1
    21
    Quote Originally Posted by ripcuda View Post

    How do you detune? Over rich-ing on the top end?
    This!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't seem to get correct oil level!
    By srjrinc in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-24-2014, 04:05 PM
  2. Sl750 must feather throttle to get on plane
    By skigolfnut in forum Polaris Open Discussion
    Replies: 23
    Last Post: 01-27-2010, 10:16 PM
  3. 94 SL750 cuts out and bogs at full throttle
    By raiderman444 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-30-2009, 09:44 PM
  4. Food: this is why I can`t seem to lose weight!
    By Pale Rider in forum Open Discussion
    Replies: 22
    Last Post: 04-17-2008, 06:43 PM
  5. I can't wait to get out to the water tomorrow!
    By Green Hulk in forum 4-Tec Performance
    Replies: 32
    Last Post: 01-16-2006, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •