Results 1 to 4 of 4
  1. #1
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,237
    +1
    44

    97 XP keeps turning off

    Did some work on a 97xp. It would start but wouldn't Rev or run. Pulled the carbs which were never rebuilt. Cleaned and re installed them with new oil lines and fuel lines. Cleaned fuel filter. It started great, revved and all then gave a single beep and shut off. It will restart just fine, run for 10 seconds, beep once and shut off. I noticed the temp sensor on the head was cracked at the plastic base but the owner wanted to still take it out on the water. We pulled the cracked plastic off and got the wire pushed back in. I didn't think it would work but it fired up and ran. He took it to the lake. Now it's doing the same thing and now he says it won't even crank, no beep with the dess key, nothing. Any ideas?


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,558
    +1
    1,806
    check the emm connectors. the emm is in perhaps the worst possible place of any seadoo.

    pull the conectors and look for any green crap or perhaps a burnt pin on the emm itself.

    before you do that, disconnect the battery and open the forward electric box, there is a fuse in there that might be blown.

    leave the rear hatch open also and let this ski air for a while before making any sparks near the fuel tank.

  3. #3
    Pwgsx's Avatar
    Join Date
    Sep 2006
    Location
    DFW- TX
    Posts
    1,237
    +1
    44
    Will do, do you think the DESS post might have gone bad? Its just strange though that it runs for exactly 10 seconds, beeps once and shuts off.

  4. #4
    Waterluvr's Avatar
    Join Date
    Mar 2015
    Location
    Northern Indiana
    Posts
    478
    +1
    69
    Quote Originally Posted by Pwgsx View Post
    Will do, do you think the DESS post might have gone bad? Its just strange though that it runs for exactly 10 seconds, beeps once and shuts off.
    What Pete said, you'll find issues there on a 97 XP like death and taxes.

    That ski uses the common Dess post connector, unplug it and try another one temporarily that's a symptom of the module losing the ground from the closed switch.

    I find the ground connections to the MPEM a mess on most of those 97's, bad corrosion on the pins and connectors most of the time had several of them again this season doing the same thing your's is although it's usually more intermittent.

    That ski has horrible vibration in the front end that kills DESS posts more than any other model made aside from some of the GTI's, new post and a very judicious cleaning of the mpem pins and spades and connectors with a once over in the e-box should get it back 100% again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 xp keeps shutting off after starting.
    By aruba yamaha in forum 2-Stroke Performance
    Replies: 4
    Last Post: 09-04-2012, 06:57 PM
  2. 97 seadoo xp trouble turning over
    By richie808 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 03-14-2010, 03:56 AM
  3. 96 XP engine wouldnt turn off...
    By 240witSR in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-06-2008, 09:20 PM
  4. GTX won't turn off when you pull the key, keeps beeping.
    By FLSUN in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-06-2008, 04:19 PM
  5. 97 xp shuts off
    By Stoffa17 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-13-2007, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •