Results 1 to 4 of 4
  1. #1
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,275
    +1
    7

    WTB: Fuji starter

    I need to find a good used starter for a Fuji engine. I've checked everything and have 12V to the starter, good ground, but I get nothing out of the starter when I push the button. Please reply or PM with what you have.

    KJ


  2. #2

    Join Date
    Aug 2014
    Location
    Richardson, Tx
    Posts
    294
    +1
    26
    I do not have a starter for you, I'm kind of looking for one myself. Have you considered rebuilding the starter you have? Rebuild kits are very inexpensive, and unless there is some damage to your rotor or stator windings, no reason at all it can't be rebuilt. I had two starters do what you are describing, and in both cases the metal plate the brushes are connected to cracked in half. Easy fix and both starters work just fine again. I would really encourage you to take yours apart and check it out. At any rate, used starters are all over Ebay, you can even buy a new one cheap enough, although most new ones sold are not genuine Mitsuba, but a copy.

    Quote Originally Posted by johnsonmtz View Post
    I need to find a good used starter for a Fuji engine. I've checked everything and have 12V to the starter, good ground, but I get nothing out of the starter when I push the button. Please reply or PM with what you have.

    KJ

  3. #3
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,549
    +1
    34
    I have clean, fresh water OE used starters here for $75+ s&h

    For payment I take Visa, and Master Card. Feel free to call the shop 608-743-1305 to order.

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,275
    +1
    7
    I figured it's rebuildable. I'm kind of thinking something inside came loose and is shorting the windings to ground. We had 3 foot rollers the day before it died and we rode the ski REALLY hard. My guess is something busted loose in all those hard hits. I may just go that route once I get it pulled and take a look. All signs point to an internal problem in the starter itself. I have good ground and 12V to the stud, but nothing happens when the solenoid engages. That has to be a dead short.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB: yamaha starters
    By WB800BLASTER in forum Yamaha Classifieds
    Replies: 0
    Last Post: 08-19-2009, 03:45 PM
  2. WTB: 951 Starter bendix
    By Joe Stang in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 01-01-2009, 10:24 AM
  3. wtb: 951 Starter
    By Joe Stang in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-30-2008, 08:31 AM
  4. wtb gp 1200 r flywheel and starter motor
    By attila in forum Yamaha Classifieds
    Replies: 1
    Last Post: 05-04-2008, 08:08 AM
  5. WTB Fuji bottom half of case
    By xlint89 in forum Polaris Classifieds
    Replies: 24
    Last Post: 05-02-2008, 12:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •