Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    nujet 1210350901 any good for my 98 xpl?

    finally running properly so changing wear ring to get rid of cavitation.
    took off impeller and see that its a nujet SD-B 6.0 - pretty good shape.
    do i keep it or change out? pretty much stock xpl (newly jetted carbs and flame arrestors with no accel pumps)

    thanks!


  2. #2
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Made in Taiwan......

  3. #3
    Good to know!
    searching through posts seems like stock is the way to go for this boat. So I will most likely go that route unless this nujet changes my mind...

  4. #4
    Changed the wear ring and cleaned the impeller blades a little.
    Better performance but holeshot is dead. Full throttle out of the hole spins out the prop... Am I correct in assuming there is too much clearance between the edges of impeller and wear ring?
    I ordered and received a pretty good looking stock impeller so I will throw that in to see what changes.

  5. #5
    This royal purple gear oil sure looks funky... Anyway do you think the clearance to the wearring is ok or am I right to think it's too much of a gap?Click image for larger version. 

Name:	image.jpg 
Views:	38 
Size:	64.6 KB 
ID:	368727Click image for larger version. 

Name:	image.jpg 
Views:	36 
Size:	57.5 KB 
ID:	368728Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	90.8 KB 
ID:	368729Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	81.6 KB 
ID:	368730

  6. #6
    Click image for larger version. 

Name:	image.jpg 
Views:	41 
Size:	134.5 KB 
ID:	368731Click image for larger version. 

Name:	image.jpg 
Views:	36 
Size:	77.3 KB 
ID:	368732This "new" used stock prop has about the same clearance as the nujet I took off.
    Not sure what to make of it...
    Also is the shaft of the pump supposed to easily slide out, I pushed it with the impeller a little when trying to screw it on and it pushed out. No lateral play but thought I would ask..

  7. #7
    I Finally was able to ride it and while this hooks much better it still 'spins out' for 2 seconds or so and then goes. there is not an instant hook up. RPMs go to 7K right away, no hesitation runs great but the water hook up is missing.
    When i installed the wear ring i thought it was strange how it just slid in without any tapping.
    I will take off the pump tomorrow to check the seal, i do see a bunch of white foam being used there as a sealant by whoever sealed it before me.

  8. #8
    and on top of it my pump oil looks to be leaking... not sure if that is because i stuck too much in there or did just not put enough thread sealant in there. damn it. Click image for larger version. 

Name:	File Sep 15, 10 04 59 PM.jpg 
Views:	36 
Size:	38.9 KB 
ID:	371065
    could be cross threaded i suppose as well even though it did not feel like it.
    what can i do about that?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	File Sep 15, 10 04 59 PM.jpg 
Views:	31 
Size:	64.1 KB 
ID:	371064  

  9. #9
    and i am pretty sure i am missing the impeller boot, is that a big issue or can it wait a weekend? and i dont think i saw a spring in the cone, is there supposed to be one there?

  10. #10
    so reading through the forum i think it could be a spinning wear ring issue?
    or maybe the shoe to hull seal? does not look easy.. any thoughts? mine already has had this done once looks like. Click image for larger version. 

Name:	File Sep 15, 11 09 07 PM.jpg 
Views:	41 
Size:	36.0 KB 
ID:	371072
    i think i actually have a receipt for it having been done last year for the previous owner.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts WTB front storage tray for my 98 XPL / XP Limited.
    By chantra in forum Sea Doo 2 Stroke Skis
    Replies: 4
    Last Post: 06-11-2013, 04:17 PM
  2. which prop should i buy for my 98 XPL?
    By Azzo in forum 2-Stroke Performance
    Replies: 61
    Last Post: 06-03-2009, 10:56 PM
  3. After Market Head Question for my 98 XPL
    By Azzo in forum 2-Stroke Performance
    Replies: 13
    Last Post: 03-11-2009, 08:24 PM
  4. ???best grate and rideplate for a 98 XPL???
    By rapidacceleration in forum 2-Stroke Performance
    Replies: 13
    Last Post: 05-06-2007, 06:27 PM
  5. Is 67.6mph good for my setup?
    By orion in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 04-25-2007, 01:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •