Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25

    Added a 2002 Virage TXi to the fleet.

    Just picked up a 2002 Virage TXi with 56 hours on it. PO said it just died on the water last time they had it out. Pics and info to follow.
    JJ


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,450
    +1
    300
    Congrats!

    (how much? )

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,777
    +1
    123
    good deal i saw that one and a genisis up by you for a good deal also

  4. #4
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25
    Picked it up for an even 1000 with the trailer. Will be digging into it this weekend. I really like the DI skis. I also like the mid 90's EFI Polaris INDYs.

    Yes thinking on getting the Genisis also.

  5. #5
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25
    Here are the test results

    New battery, compression is Mag 120, Cen 120, PTO 116. (Same as my 2001). Fuel pressure 20 lbs, (will be reinforcing the presure regulator) DC volts on red/white 30 and dropping slowly. Put it all together and start run for a second then a backfire. Will check with good EMM tomorrow when the 2001 returns from Harris.

    JJ

  6. #6
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25
    While removing the fuel pump the pressure regulator fell off. I took out all the old fuel and wiped the tank clean. I reinforced PR. I will be putting the EMM and injectors from the 2001 TXi on this one after my air sensors get in just to make sure everything is OK before sending the EMM out. Anyone use Marine Computer Supply? They do not have a email address just a form type of contact us page and a phone number. Just want to know their price point.

    JJ

  7. #7
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    18,081
    +1
    1,609
    I plan to use them when the time comes that i may need an EMM repair.

  8. #8
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25
    I install the resonator, injectors and the EMM that I just received back from Harris. I have mixed feeling about my results. It starts and idels well at 1150. It has awesome throttle response from 1150 all the way to 6690ish. It pulls hard anywhere within that band, however if I hold the throttle full open it starts to chug and RPMs fall almost 1000 before it recovers. If I maintain 6690 and below I havenot issues, if the RPMs flash above that I loose the 1000 RPMs. IS my EMM not quite right? The 2001 TXi with the MSX140 EMM and injectors seem less than a MPH slower than the MSX when riding together but this 2002 with the 2001 EMM and injectors seems about 3 MPH slower because the MSX pulls away quicker. Could it be the power band of the different years and our models?

    JJ

  9. #9
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,550
    +1
    2,711
    Quote Originally Posted by jajardas View Post
    ... It starts and idles well at 1150. It has awesome throttle response from 1150 all the way to 6690ish. It pulls hard anywhere within that band, however if I hold the throttle full open it starts to chug and RPMs fall almost 1000 before it recovers.

    If I maintain 6690 and below I have no issues, if the RPMs flash above that I loose the 1000 RPMs. Is my EMM not quite right? ...
    Well, something is not correct.

    Do you have another TPS you can try?

    Throttle cable slack set correctly, for both idle and wide open?

    Can you swap in a different EMM with matching injectors as a test?

    What RPM will it reach on the water at WOT?

  10. #10
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    594
    +1
    25
    I do have new TPS, and another EMM and matching injectors. WOT results in the ski passing 6690 RPMs and then falling to 5700 to 5800 then recovers. but if I do not stop at 6690 in falls again. I will check the throttle cable adjustment. What is the max for RPMs on these. I know the MSX tops out around 6700 =/- 50. So would this be my problem? It is trying to surpass the limit and then dropping after it passes that?

    Thanks for the feedback.

    JJ

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage TXi possible impeller problem, need to replace the entire jet pump
    By Keeper1343 in forum Polaris Tech Tips and Info
    Replies: 25
    Last Post: 05-17-2014, 10:27 AM
  2. Replies: 9
    Last Post: 06-06-2013, 09:47 AM
  3. Replies: 7
    Last Post: 06-07-2012, 07:22 PM
  4. how to take out fuel pump and filter for 2002 virage txi
    By kc44408 in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 06-24-2009, 01:27 AM
  5. 2002 Virage TXI TPS--where to buy?
    By Dirtbiker2007 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-17-2007, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •