Results 1 to 5 of 5
  1. #1
    javimuni's Avatar
    Join Date
    Aug 2013
    Location
    Fort Lauderdale, FL
    Posts
    209
    +1
    15

    Question 08 STX 15F cooling

    Is there anything that I could do to improve the cooling system on a 08 stx 15f?


  2. #2

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    972
    +1
    159
    The factory cooling systems on all the recent Kawasaki Skis are quite stout and even on modded boats don't require much fiddling. Most major systems, even the electrical charging setup has cooling. Besides making sure all hose clamps are tight, and the intake water pipe under the main intake is in good shape I can't think of too much else to do..Are you having issues?

  3. #3
    javimuni's Avatar
    Join Date
    Aug 2013
    Location
    Fort Lauderdale, FL
    Posts
    209
    +1
    15
    Thanks for the input. .. i know the intake is a magnet for seaweeds, but it seems that even after cleaning it up after clogging, the alarm kept going forever. ..had good pressure out of the pisser but the warning buzzer never stopped. And then, of course i had the hot starting issue...but thats another topic

  4. #4

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    972
    +1
    159
    I'd blow through all the lines with compressed air, and also check that intake pipe as stated above to make sure it isn't clogged. When they do it's usually from the inside and you need to remove the hose to do a full check, which means removing the whole intake assembly. Not a horrible job to do but has to be done. Start with the compressed air then move on to the more aggressive stuff. Also, check the sensor for proper resistance as stated in the factory service manual. If all that fails then you can move onto making sure the exhaust ports aren't clogged. Living in sunny Ft. Lauderdale, I'd assume you ride all salt and I've seen some clogs in the ports..

    Others may have further or better advice, but this is how I would proceed.

    Do you get the alarms on the hose?

  5. #5
    javimuni's Avatar
    Join Date
    Aug 2013
    Location
    Fort Lauderdale, FL
    Posts
    209
    +1
    15
    To be honest, I'd never put it on the hose...i always go to a canal to flush after riding...never had the alarm there....i already checked the intake on top of the pump and its good, also did the waterbox and everything is good. ..i think is the fng sensor but now I'm gonna put the resistor to see how it works on my next outing ...thanks for ur help...

  6. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Owner of '08 STX 15F
    By pilotrt in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-08-2011, 11:32 AM
  2. WTB wtb 08 stx 15f right sponsoon and rubrail and rear corner bumper
    By Daveski in forum Kawasaki Classifieds
    Replies: 5
    Last Post: 08-17-2010, 05:46 PM
  3. 08 STx 15f warranty
    By gfmoto in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-26-2009, 11:30 AM
  4. 08 stx-15f compared to 2002 stx-r
    By halfassjack in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-24-2009, 07:34 PM
  5. '08 STX-15F: Best Value "Ever" Due to Vertical Pricing Congestion
    By execjet in forum Kawasaki Open Discussion
    Replies: 14
    Last Post: 03-28-2008, 04:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •