Results 1 to 3 of 3
  1. #1

    1996 Polaris SLTX 1050 broken piston (Mag) battered head

    Can someone try to explain to me what went wrong with my engine? I have a 1996 SLTX that has a broken piston on the Magneto side and the head has a bunch of dents in it. Is this from a carb issue or did something get in the engine? I lost a washer in the carbs the other day if that helps.Click image for larger version. 

Name:	Piston.jpg 
Views:	62 
Size:	95.0 KB 
ID:	367365Click image for larger version. 

Name:	Head.jpg 
Views:	154 
Size:	77.8 KB 
ID:	367366


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,210
    +1
    1,720
    Welcome

    Was the lost washer allowed to get into the engine?

    The photos show 'foreign object damage'. It looks to my eye like a crankcase or connecting rod bearing may have come apart and the bearing pieces have been sucked up into the combustion chamber where they were beaten into the piston top and cylinder head.

    You will need to remove the cylinder and piston so you can inspect further.

    If the engine already has a high number of running hours or it has been many years since the last rebuild then a full engine rebuild may be prudent. If it is the original engine then it is twenty years old.

  3. #3
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    895
    +1
    21
    Doesn't look like a washer to me.

    I agree with 447, something probably came up from the crank. Or it could be a piece of a ring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLTX 1050
    By jasonmd13 in forum Polaris Open Discussion
    Replies: 30
    Last Post: 04-20-2013, 01:10 PM
  2. 1996 Polaris SLTX 1050 Problems
    By an32088 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-15-2012, 02:31 AM
  3. 1996 polaris sltx 1050 runs bad after 10 minutes if hard riding
    By gvnitup in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-25-2010, 09:52 AM
  4. 1996 Polaris sltx 1050 problem
    By John0227 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-09-2010, 02:39 PM
  5. 1996 Polaris sltx 1050
    By diggerbug777 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-02-2008, 10:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •