Results 1 to 5 of 5
  1. #1
    randhellg's Avatar
    Join Date
    Jun 2015
    Location
    Boston,MA
    Posts
    144
    +1
    14

    2009 fx sho with power problems!! Please help!!

    hi guys I'm actually posting on behalf of a friend who owns a 2009 FX SHO with aprox 50 hrs on it, the last time we hit the lake he sucked in some rocks and the ski started to behave weird, we replaced the impeller and checked the housing, everything checked good but the ski now is like it doesn't have power as if the supercharger is not working, i you go WOT out of the hole is really weak, and it will only go about 60mph on the dreamometer!! i checked the hoses just in case something came loose and i don't think it needs a supercharger rebuilt, guys I'm not an expert by any means I'm just trying to help a friend, any word of advise will be greatly appreciated


    thanks


  2. #2
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,273
    +1
    275
    Nice to see some more Boston guys on here, I'd take a look in person if I was a little closer. Anyways, are you sure the issue started when your friend sucked up some rocks? Sounds like you did the right thing by replacing the prop and checking the wear ring. Is it possible something in the pump is still damaged? If you think its related to the engine, pull the air intake and see if the supercharger clutch is working properly. Using your hand, spin the SC wheel..... it should ONLY spin in one direction. If it spins both ways, you will likely need a new SC clutch. What RPMs are you spinning? That ski should be around 7600rpm stock.

  3. +1 by:


  4. #3
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    671
    +1
    94
    What are your max RPMs? Can you hear the supercharger sound? Sounds like the clutch went out.

  5. +1 by:


  6. #4
    randhellg's Avatar
    Join Date
    Jun 2015
    Location
    Boston,MA
    Posts
    144
    +1
    14
    Quote Originally Posted by HydroStream6 View Post
    What are your max RPMs? Can you hear the supercharger sound? Sounds like the clutch went out.
    thanks guys i will check that sc clutch and keep you posted, i didn't checked the rpms but the engine sounded like it was tired and out of power

  7. #5
    HydroStream6's Avatar
    Join Date
    Jun 2012
    Location
    New York
    Posts
    671
    +1
    94
    If the engine was a lot quieter than normal, probably the SC clutch. It's not a bad job to change it. Just pricey.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 FX SHO sudden power loss
    By ryan15 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-16-2016, 05:15 PM
  2. 2009 fx sho with low speed need advice
    By deivid02 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-17-2015, 04:58 PM
  3. 2009 FX SHO Weird Electrical Problem, Won't Start
    By jasonstackhouse in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 07-04-2015, 05:42 AM
  4. 2009 fx sho rpms running too high, help!
    By borghesa in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 02-20-2011, 10:14 PM
  5. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •