Results 1 to 6 of 6
  1. #1
    Paul2005GPR's Avatar
    Join Date
    Oct 2009
    Location
    Northern Illinois
    Posts
    704
    +1
    42

    Ficht 1200 starting issue

    Just had emm rebuilt. New fuel line restrictor as the factory one fell out, drained and refilled with new gas, will crank and crank and not start but if you shoot a little fuel in the tb throats, it will start and run fine until you shut it off....also it will only die with the tether, start/stop won't shut it off...need advice.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,202
    +1
    1,716
    Quote Originally Posted by Paul2005GPR View Post
    Just had emm rebuilt. New fuel line restrictor as the factory one fell out, drained and refilled with new gas, will crank and crank and not start but if you shoot a little fuel in the tb throats, it will start and run fine until you shut it off....also it will only die with the tether, start/stop won't shut it off...need advice.
    Which year and model is this machine?

    The LR-503 Start/Stop module controls engine stop using the push button, so the LR module is suspect.

    What new fuel line restrictor did you use?

    Not starting unless primed with gasoline is typically an indication of weak voltage at the fuel injectors during cranking. The most common cause is the EMM needs repair, but sometimes it is the stator coils or the flywheel magnets.

    You can ohm test the Ficht stator coils. All five coils should have similar ohms, these are very low ohms numbers with two of the coils being slightly different from the other three. All five stator coils should have no connection at all to engine ground.

  3. #3
    Paul2005GPR's Avatar
    Join Date
    Oct 2009
    Location
    Northern Illinois
    Posts
    704
    +1
    42
    2003 genssis

  4. #4
    Paul2005GPR's Avatar
    Join Date
    Oct 2009
    Location
    Northern Illinois
    Posts
    704
    +1
    42
    It will start on its own if I turn my booster charger all the way up...new battery?

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,202
    +1
    1,716
    Quote Originally Posted by Paul2005GPR View Post
    It will start on its own if I turn my booster charger all the way up...new battery?
    My guess is that the EMM or the stator has issues. Cranking it with excessive battery voltage (how high are you pushing it?) makes it crank faster than normal so the magneto voltage outputs are higher than normal, enough to get it to light off, it appears.

  6. #6
    Paul2005GPR's Avatar
    Join Date
    Oct 2009
    Location
    Northern Illinois
    Posts
    704
    +1
    42
    Hmm, just had the emm rebuilt, when cranking with the charger, the dash says like 18v this is ramping up my voltage and letting it start, the battery in it is junk so I will get a new battery and then test the stator output..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Xll 1200 warm starting issue
    By Paul2005GPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-04-2014, 09:01 AM
  2. 98 gp 1200 starting and idle issues
    By i2quick in forum Yamaha Old School Skis
    Replies: 15
    Last Post: 07-05-2012, 10:38 PM
  3. 2003 Polaris Genesis i 1200 starting issue
    By madison in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 10-12-2011, 09:43 PM
  4. 1999 Genesis FICHT hard start and other issues
    By Engineer in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 06-25-2010, 04:58 PM
  5. 2000 Polaris Pro 1200 Start issues?
    By rdizz81 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-07-2010, 10:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •