Results 1 to 2 of 2
  1. #1

    rxDi surging loss of power issue

    2003 rxdi with fresh rebuild.
    After running at wot throttle for a minute or so the power drops off and it will surge. If I leave of throttle to idle for a few seconds sometime it will run good other times it will surge.
    Fuel pressure good.
    During one run the rear plug was fouled.
    My thought are possible plug lead or coil breaking down at wot.
    Any other suggestions please


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,270
    +1
    183
    Why was it rebuilt in the first place? Were all 3 fuel filters replaced? You could have an over-charging rectifier. Put volt meter on battery, fire it up, then rev it up and see what the voltage does.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 250X misfire, surge, loss of power
    By Littlet in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 09-05-2012, 10:47 AM
  2. Loss Of Power/RPM Drop
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-26-2007, 12:44 PM
  3. loss of power ( Max rpm 7000 ) after 7 hours
    By LAB69 in forum 4-Tec Performance
    Replies: 34
    Last Post: 04-02-2007, 04:59 PM
  4. 96 sl900 loss of power
    By scorp in forum Polaris Open Discussion
    Replies: 11
    Last Post: 01-08-2007, 07:18 PM
  5. Loss of power 04 RXP
    By PossisRXP in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-14-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •