Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    1999 slx 1200 cdi problem

    So i guess lets just dive in. im a 15 year old kid from texas and me and my father bought a 2 stroke 1999 Polaris slx ski as a toy/project to work on together.
    the first time we got it on the water it was amazing for about 30 mins... then she started to bog down wouldn't go past idle. after weeks of messing with it ( full rebuilding of all 3 carbs, replaced all fuel lines, replaced spark plugs, replaced battery ) we got it better now it just wont go past 3500 rpm.
    after lots of time and money my father has pretty much given up. ( i mean rightfully so its been quite the head ache ) anyways i still want to get it fixed so without him ive been looking on fourms and learning all about this, after some trouble shooting i found piston 1 was not firing at all, after banging my head trying to figure out why we never realized this before i replaced all 3 plugs just to be sure. but wait... same problem. i checked the ebox nothing is out of place or loose/disconnected, checked the plug wires and cleaned them all no luck.. So maybe some of you who are allot smarter than me can tell me if im right on the cdi or its something else?

    Unfortunately being 15 i have little to no funds to work on this...
    the new cdi ive found for $150!!! there is no way i will be able to convince my parents to buy that and i cant afford it myself. i have found a generic cdi on ebay for $28 theres no way this would work, would it? http://www.ebay.com/itm/261960562715

    after talking with a few in the know more than me ive heard it could be the stator or the ignition coil also. me being farily new to this im not sure what thoes even are.
    is there any way i can know for sure what the problem is? maybe that could help convince my parents to buy parts if i know exactly what it is.
    the only real reason i know what a cdi is was because i have replaced one on a smaller 2 stroke motor in the past.

    thanks allot for your help and sorry for the grammar and spelling mastakes


  2. #2
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,414
    +1
    1,474
    Chances are the coil is good. Those almost never fail. Look in your electric box. What is the part number on the CDI? Im going to guess you have the original non-updated ignition system. Limiting RPM around 3500 is a sign of a failing stator on the original ignitions.

    The link to the CDI you have is not compatible with these ignitions.

    Unfortunately the kit you may need to upgrade your ignition is 600 bucks.

    http://www.shopsbt.com/cdi/polaris-i...-SLX-1999.html

    Get the part number off the CDI you have now and we can help from there.

  3. #3
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,414
    +1
    1,474
    Where are you located? There may be someone local that can help out.

  4. #4
    another bit i was doing some testing and while started its only running on 2 of 3 cylinders i unplugged the boot on one of the working cylinders so its only running on 1 and i could hear what i thought to be the dead cylinder firing once about every 30 seconds or so. what gets me is it is not random its on a exact interval so it couldnt be a loose wire somewhere right?

    here is a picture of the cdi although the rpm does not feel limited its almost as if the engine is starving for gas if i go past 3500 rpm. something i did not mention before is it will go to high rpms briefly for a few seconds and then start cutting out. also this is all in water. on the trailer hooked up to the hose it has no problem climbing up in rpm. any thoughts?
    Click image for larger version. 

Name:	image1.JPG 
Views:	60 
Size:	139.6 KB 
ID:	366847

    EDIT: thanks for the quick reply!

  5. #5
    that would kinda be a last resort type of thing i really need to avoid spending any money

  6. #6
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,414
    +1
    1,474
    THat picture is the coil. The CDI is connected to the coil with the bullet plugs on the small wires.

    Running on the hose means nothing. There is no load on the engine. I find running on the hose a waste of time. A better test is on the trailer backed into the water, with the ski strapped down.

  7. #7
    I agree with the hose but i would like to get this cylinder at least fireing before i make the trip to the lake, no?

    sorry about that is this what you wanted?Click image for larger version. 

Name:	image1.JPG 
Views:	66 
Size:	130.4 KB 
ID:	366857

  8. #8
    CliffsidePM's Avatar
    Join Date
    May 2014
    Location
    Racine, WI
    Posts
    584
    +1
    25
    The 1999 SLX was a 1050 not a 1200. So correct year may help us. Last digits of hull number.

    Also check to make sure you have the plug wires connected correctly. Some of these coil packs are not in the same order. I have attached a picture of the order.

    GOOD Luck
    JJ
    Attached Files Attached Files

  9. #9
    MSX 150 guy lives on Mr. GP1800's Avatar
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    17,414
    +1
    1,474
    Quote Originally Posted by iungerich1 View Post
    I agree with the hose but i would like to get this cylinder at least fireing before i make the trip to the lake, no?

    sorry about that is this what you wanted?Click image for larger version. 

Name:	image1.JPG 
Views:	66 
Size:	130.4 KB 
ID:	366857

    Good news......You have the updated CDI.

    If you have spark your CDI is most likely good.

  10. +1 by:


  11. #10
    sorry about that. last 2 digits are 99. and thanks for the diagram i will check that after im done cleaning the house :P

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slx 1200 cdi
    By ilovemyskidoo in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-23-2015, 12:53 PM
  2. looking for a 1999 slx 1050 cdi box!!!!
    By h2jim in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-28-2010, 10:20 AM
  3. polaris slx 1200 cdi gray wire
    By chandlerwelding in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-22-2010, 01:24 PM
  4. 2000 SLX 1200, Intermitent Spark Problem
    By KSCTim in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-29-2008, 12:21 PM
  5. slx 1200 problem
    By posfit in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-26-2007, 06:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •