Results 1 to 8 of 8
  1. #1
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    301
    +1
    9

    Exclamation 2011 GTX Ltd iS Factory drive shaft alignment issue!

    From my experience Factory Drive shaft alignment (Pump Support Alignment) is off about 60% of the time from the factory. Most time's it can easily be worked around by shimming the motor properly to the drive shaft or pulling the pump support and aligning it properly to the hull. But this is on the traditional pump support set up seadoo has been running for years. What are my options on the Suspension models where the pump bolts directly to the ride plate? Can the OEM ride plates be shimmed and reglued to solve the driveshaft alignment issue to the hull with out any issue?


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,683
    +1
    516
    if your going to align it, upgrade to the old/ new parts
    they only used that pump bolted to the ride plate a few years and went back to the old style pump support
    but its not a easy job on a regular ski , doing it on a as ski.....good luck

  3. #3
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    301
    +1
    9
    its a customers ski and the insurance only approved 10 hrs for complete r and r of engine and replacement of front and rear oil pumps an oil pressure regulator. im just trying to get the pump aligned to the hull.

  4. #4
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    301
    +1
    9
    its way out the alignment shaft is nearly touching the top of the thru hull fitting. Id have to jack the motor up atleast an inch and im not down with that.

  5. #5
    Pete1027's Avatar
    Join Date
    Jul 2012
    Location
    Adelaide, AUSTRALIA
    Posts
    472
    +1
    15
    http://www.greenhulk.net/forums/showthread.php?t=218638

    Have a read. Might help. Might not.

  6. #6
    bmxjoe's Avatar
    Join Date
    Jun 2012
    Location
    Fort Walton Beach, Fl
    Posts
    301
    +1
    9
    Ill give it a read. Thanks alot man!!!

  7. #7
    kaiser's Avatar
    Join Date
    Jan 2008
    Location
    western pa.
    Posts
    140
    +1
    6
    this is absolutely inexcusable such a critical spec. this should be done right at assembly this causes carbon seal failures and sinking one of the reasons I got a Kawi 300 but I still luv the Doos though but it cost them a ski who wants to sink 5 miles from shore I hope BRP is paying attention.

  8. +1 by:


  9. #8
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,683
    +1
    516
    carbon seal or a exhaust hose comes off they all can sink

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 01-20-2012, 04:39 PM
  2. fuel gauge stuck on two bars - 2011 GTX Ltd iS 260
    By GazUK in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-08-2011, 02:53 AM
  3. 2010 & 2011 gtx ltd is 260
    By moultrie rxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 02-23-2011, 02:10 PM
  4. help: drive shaft alignment
    By earl in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 08-21-2007, 08:10 AM
  5. Is this drive shaft too far gone?
    By Therock in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-20-2007, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •