Page 1 of 3 123 LastLast
Results 1 to 10 of 30
  1. #1
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166

    Rxp mph not where expected

    Hey guys need some help here... I went out yesterday and made a few runs. Weather in fla was about 90f and water temp was 88. Ski pulled 8000/8050 and a top mph of 69.9. This is in salt water. Here's what I installed.

    fizzle xs cooler
    les Cooke a kit wheel for 215
    42lb injectors, seems rich at idle, huffs black smoke a little
    15/20 prop re pitched to either a 14/18 or 14/19. Can't remember
    Riva 3" intake. I also have a 4"rear air but didn't install yet.

    I was aiming for around 73mph and it seems like a long way off still. A few have mentioned to me to install the rear air, but I don't see that gaining that much speed. Anyone have any ideas? I feel like the ski wasn't crazy fast like I though it would be. Hole shot is ok with no cavitation. And when it's up on the top end it feels really strong but the mph isn't there.


    thanks again


  2. #2
    What's you're afrs at wot ?

  3. #3
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    Not sure everyone said it's more then safe with my setup so I didn't mess with putting a wideband on

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,990
    +1
    1,407
    What intake grate are you running?

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,990
    +1
    1,407
    Quote Originally Posted by Kmorningstar_rxp View Post
    Not sure everyone said it's more then safe with my setup so I didn't mess with putting a wideband on
    You probably are safe, but anytime you start swapping wheels and injectors, it is usually best to have a way to monitor and adjust fuel.

  6. #6
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    Stock intake grate. Wideband wise I've used them on cars In the past but didn't think it was a must have for what I'm doing. Is the black smoke normal for these injectors? With stock ecu

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,990
    +1
    1,407
    Quote Originally Posted by Kmorningstar_rxp View Post
    Stock intake grate. Wideband wise I've used them on cars In the past but didn't think it was a must have for what I'm doing. Is the black smoke normal for these injectors? With stock ecu
    Stock grate is slowing you down some.
    Wideband is not a must have, but it does help, being your ECU still thinks it has stock injectors and wheel.

  8. #8
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    On my 2005 RXP I ran 75 (GPS) mph all day with that setup, and hit 77 often, when the weather was 80 degrees or less. This was at 8100 rpms with rear air.

    Things to do: 1. Install rear air - it is worth 1+ mph usually. 2. Spend some time underneath, grind/sand the ride plate to get it smooth, make sure grate is mounted correctly and tucked up nicely. Can be 2+ mph down here if you make everything 'right' 3. Check your cam timing, full retard may net you 1+ mph depending where you are at now. 4. Install R&D grate for better hookup and pump loading.

    This setup is a little rich at idle as you noticed. What size nozzle are you running?

  9. +1 by:


  10. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,990
    +1
    1,407
    Quote Originally Posted by Kmorningstar_rxp View Post
    Is the black smoke normal for these injectors? With stock ecu
    I would say no. Being to rich or burning oil would do that.

  11. #10
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    Nozzle is bored out to fit fizzle reduction rings. I think it's 88mm. Yeah just seems so far off with what I wanted:/

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP 215, not sure where to start!
    By Waitey in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-09-2013, 04:30 AM
  2. RXP will not start, PLEASE HELP!
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-27-2007, 05:36 PM
  3. Sbc Good engine or not, if not where to go???
    By gvnitup in forum Polaris Open Discussion
    Replies: 17
    Last Post: 04-22-2007, 09:03 AM
  4. 2005 RXP Trim not working?
    By idizzy in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-27-2006, 05:41 PM
  5. GPS numbers not where I want them to be
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-07-2006, 07:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •