Results 1 to 4 of 4
  1. #1
    Hold my beer and watch this... JohnnyMac's Avatar
    Join Date
    Apr 2015
    Location
    Columbia River
    Posts
    193
    +1
    26

    2009 Wake Pro noise

    Hi all,
    My 2009 Wake Pro 215 started making a funny kind of rattling type noise. Seems to only happen in the 4-5k rpm zone (or at least that's when I hear it) and it's especially noticeable when pulling a knee board or tube. Below 3500 rpms and at WOT I don't believe I hear it and it runs up to 7900ish rpms and 69mph on the dreamometer with no problems. It does seem to cavitate a bit and looking at the impeller, it's a bit beat up. The wear ring has marks in it from sucking something through it although seems to be not too bad but I've got a new impeller/wear ring on order. I bought it with 19hrs on it and in the last month have it up to 28 hours. This started yesterday and I never heard it do it before yesterday. Could this be the impeller making the noise? The supercharger? Oil is right on and clean. Also, does this year have ceramic supercharger washers? Thanks!!
    Last edited by JohnnyMac; 07-27-2015 at 12:08 AM. Reason: Subscribed....


  2. #2

    Join Date
    Jul 2015
    Location
    Ma
    Posts
    126
    +1
    12
    Quote Originally Posted by JohnnyMac View Post
    Hi all,
    My 2009 Wake Pro 215 started making a funny kind of rattling type noise. Seems to only happen in the 4-5k rpm zone (or at least that's when I hear it) and it's especially noticeable when pulling a knee board or tube. Below 3500 rpms and at WOT I don't believe I hear it and it runs up to 7900ish rpms and 69mph on the dreamometer with no problems. It does seem to cavitate a bit and looking at the impeller, it's a bit beat up. The wear ring has marks in it from sucking something through it although seems to be not too bad but I've got a new impeller/wear ring on order. I bought it with 19hrs on it and in the last month have it up to 28 hours. This started yesterday and I never heard it do it before yesterday. Could this be the impeller making the noise? The supercharger? Oil is right on and clean. Also, does this year have ceramic supercharger washers? Thanks!!
    NO, that year doesn't have the ceramic washers. I would start with the Wear ring and impeller first. When you pull the cone off of the jet pump check to make sure you don't have any water contamination in the grease/bearing. Change the grease as well and be sure to use marine grade grease upon re-install

  3. #3
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,244
    +1
    995
    If you pull the cone, mix the grease with some 90W gear oil to a consistency a little thicker than molasses so the bearings have a constant feed of lube. Pure grease can starve the bearings because it just sits on the edges of the cone.

  4. #4
    Hold my beer and watch this... JohnnyMac's Avatar
    Join Date
    Apr 2015
    Location
    Columbia River
    Posts
    193
    +1
    26
    Roger that guys. I just dropped it off at the shop for a fuel pump issue so when it gets back I'll change out the impeller/wear ring and use CCW's tip on the 90W. I did my GTi's impeller a couple months ago and did note that all the grease was pushed to the outside of the cone and I thought that was fairly useless. Thanks again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 wake pro what to look for
    By HDAV in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-19-2015, 03:01 PM
  2. 2009 Wake Pro experience
    By JohnnyMac in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-28-2015, 12:17 PM
  3. Wake Pro 215, 2009 - top speed 64.9 mph on GPS
    By R12Xer in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-12-2014, 07:22 PM
  4. First Impressions/First ride 2010 Wake Pro 215.
    By vonnie in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-25-2010, 12:19 PM
  5. Seadoo wake pro 215 good boat ?
    By sloan_william@msn.com in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-25-2008, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •